Bug 1102085 - deleting of EC2 guests - confusing message
Summary: deleting of EC2 guests - confusing message
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: WebUI
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
low
low vote
Target Milestone: Unspecified
Assignee: jmagen@redhat.com
QA Contact: Martin Korbel
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-05-28 13:05 UTC by Martin Korbel
Modified: 2019-09-26 15:44 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-11 12:28:31 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 5969 0 None None None 2016-04-22 16:01:26 UTC

Description Martin Korbel 2014-05-28 13:05:19 UTC
Description of problem:
We have a EC2 guest in Sat6.0.
When we delete it, we get a information message "Successfully deleted", but the guest is still contained in EC2 (and in "Compute Resource" > "Virtual Machines"). Amazon deletes guest with the delay (in my case  10 - 60 min).
it means, the message is inaccurate. It would be better something as "The virtual machine will be deleted in few minutes".


Question is it, the difference between the deleting of host ("Hosts" > "All hosts" > delete some of EC2 guests) and deleting of a virtual machine ("Infrastructure" > "Compute resource" > some of EC2 resources > "Virtual Machines" > some of EC2 guests). 

First option deletes the host immediately and VM will be automatically deleted in future. In this case, the message is acceptable, we don't see already host in list.

Second option  marks VM for deleting and VM will be automatically deleted in future. In this case, the message is confusing, because we see still the VM in list. 

Version-Release number of selected component (if applicable):
Satellite-6.0.3-RHEL-6-20140523.0

How reproducible:
100%

Steps to Reproduce:
1. We have got Sat 6.0 with some EC2 guest.
2. Open detail of VM guest "Infrastructure" > "Compute resource" > some of EC2 resources > "Virtual Machines" > some of EC2 guests
3. Click on the "Delete" button.
4. We can see message "Successfully deleted", but VM is still in the list.

Actual results:
"Successfully deleted"

Expected results:
"The virtual machine will be deleted in a few minutes"

Additional info:

Comment 1 RHEL Program Management 2014-05-28 13:25:07 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Dominic Cleal 2014-05-28 13:59:21 UTC
Created redmine issue http://projects.theforeman.org/issues/5969 from this bug

Comment 4 jmagen@redhat.com 2014-06-01 12:52:07 UTC
https://github.com/theforeman/foreman/pull/1490

Is this destroy message true for all types of compute resources, or just EC2?

Comment 5 Martin Korbel 2014-06-02 06:08:49 UTC
jhutar tested a KVM quests.

Comment 6 Martin Korbel 2014-06-11 08:59:03 UTC
RHEV guests are immediately removed.

Comment 7 jmagen@redhat.com 2014-06-11 10:48:19 UTC
Martin, what do you when by your comment?
Are you suggesting a downstream patch to change the wording for Sat6 only

Comment 8 Martin Korbel 2014-06-11 12:10:11 UTC
(In reply to jmagen@redhat.com from comment #7)
> Martin, what do you when by your comment?
> Are you suggesting a downstream patch to change the wording for Sat6 only

No, it is my mistake, I did not notice the bug is already fixed. My commment 6 says, When I delete RHEV guest using satellite 6, the guest is removed from RHEV online. It is the difference between EC2 and RHEV (or libvirt) guests.

Comment 9 Jan Hutař 2014-06-17 20:27:25 UTC
(In reply to jmagen@redhat.com from comment #4)
> https://github.com/theforeman/foreman/pull/1490
> 
> Is this destroy message true for all types of compute resources, or just EC2?

(In reply to Martin Korbel from comment #5)
> jhutar tested a KVM quests.

Sorry for late answer. For libvirt compute resource I see removed guest to disappear (almost?) instantly.

Comment 10 jmagen@redhat.com 2014-06-18 06:32:50 UTC
Jan,

So are you suggesting to change the message wording from 
"The virtual machine will be deleted in a few minutes" 

to

"The virtual machine is being deleted in the background"

Comment 11 Bryan Kearney 2014-07-09 16:02:15 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/5969 has been closed
-------------
Joseph Magen
https://github.com/theforeman/foreman/pull/1490
-------------
Dominic Cleal
https://github.com/theforeman/foreman/pull/1490
-------------
Joseph Magen
Applied in changeset commit:9d9523c7c7472634e5fb9ed9314b06e1c62c6e96.

Comment 14 Martin Korbel 2014-09-04 14:07:19 UTC
Verification on Satellite-6.0.4-RHEL-6-20140829.0

New message is "The virtual machine is being deleted.".

Comment 15 Bryan Kearney 2014-09-11 12:28:31 UTC
This was delivered with Satellite 6.0 which was released on 10 September 2014.


Note You need to log in before you can comment on or make changes to this bug.