Bug 110239 - escape sequences in filenames (ls)
Summary: escape sequences in filenames (ls)
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: busybox (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: s390x Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-11-17 14:43 UTC by Karsten Hopp
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-14 09:49:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
this patch works for me and disables color-ls (8.94 KB, patch)
2004-03-19 23:29 UTC, Karsten Hopp
no flags Details | Diff

Description Karsten Hopp 2003-11-17 14:43:29 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.4.1)
Gecko/20031030

Description of problem:
busybox ls writes escapes sequences (colors ?) before filenames when
used in a 3270 terminal during mainframe installation.
export TERM=dumb doesn't help.

Version-Release number of selected component (if applicable):
busybox-1.00-2

How reproducible:
Always

Steps to Reproduce:
1. start mainframe installation
2. try to list directories in 3270 terminal
3. have to fall back to echo * to get readable directory listings
    

Actual Results:  # ls -1 /
 �1;36mbin �0m 
 �1;34mdev �0m 
 �1;34metc �0m 
 �1;34mlib �0m 
 �1;34mlib64 �0m 
 �1;32mlinuxrc �0m 
 �1;34mlost+found �0m
 �1;34mmnt �0m 
 �1;34mmnt1 �0m 
 �1;34mmodules �0m 
 �1;34mproc �0m 
 �1;34msbin �0m 
 �1;34mtmp �0m 
 �1;34musr �0m 
 �1;34mvar �0m 


Expected Results:  normal listings

Additional info:

Comment 2 Daniel Walsh 2004-01-05 22:08:17 UTC
busybox-1.0.0-pre5 is in the pool.  Does this one show this behavior.

Comment 3 Karsten Hopp 2004-03-19 19:32:37 UTC
Started looking at the mainframe installer again with the FC2 
packages. 
ls still prints lots of escape sequences and makes the output 
unreadable. 
Tested with busybox-1.00.pre5-3 

Comment 4 Karsten Hopp 2004-03-19 23:29:01 UTC
Created attachment 98698 [details]
this patch works for me and disables color-ls

patch against busybox-1_00_pre5-3

Comment 5 Karsten Hopp 2004-06-14 09:49:54 UTC
current busybox is ok 


Note You need to log in before you can comment on or make changes to this bug.