This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 110246 - /etc/sysconfig/rhn/sources incorrect URLs after redirects dropped
/etc/sysconfig/rhn/sources incorrect URLs after redirects dropped
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: up2date (Show other bugs)
1
All Linux
high Severity medium
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-17 10:13 EST by Gene Czarcinski
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-24 17:12:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Gene Czarcinski 2003-11-17 10:13:00 EST
Description of problem:
Sometime Friday or over the weekend (14 Nov to 16 Nov) the redirects
being performed by http://fedora.redhat.com to
http://download.fedora.redhat.com were dropped.

While this is OK and maybe there should never have been redirects,
this leaves the URLs in /etc/sysconfig/rhn/sources incorrect.

This is going to be difficult to correct in the right way.  My
suggestions:

1. Restore the redirects.

2. Issue an updated up2date package with the "new" URLs based on
download.fedora.redhat.com.

Sometime in the future you may be able to drop the redirects but since
this is built into the ISO images, it may take some time whithout
screwing novice users.
Comment 1 Anders Kaseorg 2003-11-17 12:55:56 EST
The redirects are back, but that isn't good enough because rhn-applet
doesn't follow them, giving the appearance that no updates are
available (bug #110133). Most users won't know even if updates to
up2date and rhn-applet are released.
Comment 2 Gene Czarcinski 2003-11-17 13:35:00 EST
Actually, the updated rhn-applet-2.1.4-2 package in fedora updates
does seem to handle redirects.

However, this could come back if the redirects disappear again AND the
uRLs in /etc/sysconfig/rhn/sources differ from thos listed on
http://fedora.redhat.com/download/updates.html

Choose one scheme and stick to it.

I assume that the redirects are handy and allow the actual target to
move without changing URLs.  It is also handy in changing protocols --
http access to the iso images is redirected ("transparently") to ftp.
Comment 3 Anders Kaseorg 2003-11-17 13:51:30 EST
Even if an rhn-applet update is available, bug #110133 prevents many
users from seeing the very update that fixes it! They'll just see the
blue checkmark and assume their system is fully updated. The only way
to make these users aware of the update is to use a symlink instead of
a redirect.

Note You need to log in before you can comment on or make changes to this bug.