Bug 1102524 - Dist-geo-rep : geo-rep resume after 120 sec of pause, would make geo-rep faulty and restarts instead of resuming.
Summary: Dist-geo-rep : geo-rep resume after 120 sec of pause, would make geo-rep faul...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: geo-replication
Version: rhgs-3.0
Hardware: x86_64
OS: Linux
medium
high
Target Milestone: ---
: ---
Assignee: Bug Updates Notification Mailing List
QA Contact: storage-qa-internal@redhat.com
URL:
Whiteboard: usability
Depends On:
Blocks: 1087818
TreeView+ depends on / blocked
 
Reported: 2014-05-29 06:43 UTC by Vijaykumar Koppad
Modified: 2018-04-16 15:58 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Known Issue
Doc Text:
The Geo-replication worker goes to faulty state and restarts when resumed. It works as expected when it is restarted, but takes more time to synchronize compared to resume.
Clone Of:
Environment:
Last Closed: 2018-04-16 15:58:16 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Vijaykumar Koppad 2014-05-29 06:43:17 UTC
Description of problem: geo-rep resume after 120 sec of pause, would restart geo-rep instead of resuming.


Version-Release number of selected component (if applicable): glusterfs-3.6.0.9-1.el6rhs


How reproducible: Happens everytime.


Steps to Reproduce:
1. create and start a geo-rep relationship between master and slave. 
2. start creating data on master.
3. Pause the geo-rep for more than 120 sec and resume it.
4. Check the status of the geo-rep 

Actual results: geo-rep goes to faulty for some time.


Expected results: when resumed, it should actually resume syncing, not restarting the geo-rep.


Additional info:

Comment 2 Nagaprasad Sathyanarayana 2014-06-05 07:22:49 UTC
As agreed by Dev leads, QE and PM, moving the BZ to future release.  The issue is not severe as sync of files resumes from the last checkpoint and it does not crawl the entire file system.

Comment 3 Shalaka 2014-06-27 11:11:49 UTC
Please review and signoff edited dox text.

Comment 7 Aravinda VK 2015-01-20 09:14:57 UTC
Changing priority to Medium since the pause/resume is used only while taking snapshot. After resume, georep worker goes faulty, Monitor restarts the worker and geo-rep will become Stable.


Note You need to log in before you can comment on or make changes to this bug.