Bug 110260 - Kernel 2.4.22-1.2115.nptlsmp hangs at "Ok, booting the kernel"
Summary: Kernel 2.4.22-1.2115.nptlsmp hangs at "Ok, booting the kernel"
Status: CLOSED DUPLICATE of bug 107880
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 1
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-11-17 17:36 UTC by Joseph Bironas
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:00:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joseph Bironas 2003-11-17 17:36:15 UTC
Description of problem:

Kernel for i686 architecture on SMP (2x Pent 3/500) machine (Dell
Precision 610) with a 440GX chipset hangs at boot. Grub reports
loading the kernel and initrd and then fails with the last text output
reading "Ok, booting the kernel"

Version-Release number of selected component (if applicable):

kernel 2.4.22-1.2115.nptlsmp

How reproducible:

Every time

Steps to Reproduce:
1. Reboot the machine
2. Select the SMP kernel form the Grub Menu
3. Watch as the machine hangs
  
Actual results:

Complete output--
    Booting 'Fedora Core (2.4.22-1.2115.nptlsmp)'

root (hd0,0)
  filesystem type is ext2fs, partition type 0x83
kernel /vmlinuz-2.4.22-1.2115.nptlsmp ro root=/dev/Volume00/LogVol00
  [ Linux-bzImage, setup=0x1400, size=0x148493]
initrd /initrd-2.4.22-1.2115.nptlsmp.img
  [ Linux-initrd @0x1ff60000, 0x8dd39 bytes

Uncompressing Linux... Ok, booting the kernel

Expected results:

Some dmesgs, some init scripts running, and eventually an X login
screen that looks similar to the fedora core GDM theme.

Additional info:

I've tried recompiling the kernel without APIC, using 'noapic' in the
boot config, using the 2.6test9 kernel, all with the exact same
results. The most recent kernel that actually boots SMP is the RedHat
9 version (2.4.20-20.9smp). The Non-SMP FC1 kernel
(2.4.22-1.2115.nptl) boots without any issues as well. There is no
mechanism in the BIOS to set the SMP dialect as research says many
other issues that are similar prescribe (along with the noapic thing
which makes no difference).

If there's anything I can do to help debug this, I would be glad to,
but I'm obviously not a kernel hack.

Comment 1 Joseph Bironas 2003-11-18 00:21:55 UTC
I've been able to work around the issue with by disabling APIC in the
BIOS. This leads me to believe that there is some faulty APIC handling
between the 440GX and the kernel (something that's been reported before).

It might be nice for this to be worked out in software rather than by
tweaking the BIOS (but frankly I don't care as long as it works). 

Comment 2 Dave Jones 2003-11-20 19:16:59 UTC

*** This bug has been marked as a duplicate of 107880 ***

Comment 3 Red Hat Bugzilla 2006-02-21 19:00:02 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.