Bug 1102627 - RHEL6: ksh not giving error on "cd" to directory without execute bit
Summary: RHEL6: ksh not giving error on "cd" to directory without execute bit
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ksh
Version: 6.5
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Michal Hlavinka
QA Contact: Martin Kyral
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-05-29 10:50 UTC by Seiji Nishikawa
Modified: 2018-12-09 17:54 UTC (History)
3 users (show)

Fixed In Version: ksh-20120801-17.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1109893 (view as bug list)
Environment:
Last Closed: 2014-10-14 07:07:35 UTC
Target Upstream Version:


Attachments (Terms of Use)
patch to fix this (551 bytes, patch)
2014-06-16 14:52 UTC, Michal Hlavinka
no flags Details | Diff


Links
System ID Private Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 970843 0 None None None Never
Red Hat Product Errata RHBA-2014:1381 0 normal SHIPPED_LIVE ksh bug fix update 2014-10-14 01:28:24 UTC

Description Seiji Nishikawa 2014-05-29 10:50:39 UTC
Description of problem:
 ksh not giving error on "cd" to directory without execute bit.
 It does not return an error if we "cd" to a directory without execute bit.

Version-Release number of selected component (if applicable):
 RHEL6.5 (2.6.32-431.5.1.el6.x86_64)
 ksh-20120801-10.el6_5.5.x86_64

How reproducible:
 100%

Steps to Reproduce:
1. Create a directory.
2. Run "chmod 660" to the directory.
3. When running "cd" to the directory, it does not return error "permission denied". "pwd" shows the path to the directory. But "ls" shows the contents of the previous path.

# ksh
$ pwd
/home/user001
$ ls
file01	file02
$ mkdir dir01
$ chmod 660 dir01
$ cd dir01
$ pwd
/home/user001/dir01
$ ls 
dir01  file01  file02
$ ll
total 4
drw-rw----. 2 user001 user001 4096 May 29 19:44 dir01
-rw-rw-r--. 1 user001 user001    0 May 29 19:43 file01
-rw-rw-r--. 1 user001 user001    0 May 29 19:43 file02

Actual results:
 It does not return error "permission denied". "pwd" shows the path to the directory. But "ls" shows the contents of the previous path.

Expected results:
 Error "permission Denied" should be returned against "cd" to a directory of which permission 660.

Additional info:

Comment 2 Michal Hlavinka 2014-06-16 14:52:49 UTC
Created attachment 909162 [details]
patch to fix this

Comment 8 errata-xmlrpc 2014-10-14 07:07:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1381.html


Note You need to log in before you can comment on or make changes to this bug.