Bug 110267 - TB Conf.py:936:__setitem__:TypeError: illegal argument type for built-in operation
TB Conf.py:936:__setitem__:TypeError: illegal argument type for built-in oper...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
8.0
i586 Linux
low Severity low
: ---
: ---
Assigned To: Harald Hoyer
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-17 13:50 EST by Bart Wahlgren
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-03 15:15:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bart Wahlgren 2003-11-17 13:50:29 EST
Description of problem:
When attempting to make changes to the network configuration the 
application crashes. 

Version-Release number of selected component (if applicable):


How reproducible:
Every Time


Steps to Reproduce:
1.Open the network configuration application.
2.Make changes to any of the network interfaces.
3.Click accept changes to save.
  
Actual results:
The application crashes and generates a bug report dialog box.


Expected results:
The configuration parameters should be saved.

Additional info:
Comment 1 Bart Wahlgren 2003-11-17 13:52:21 EST
Text of error:

Traceback (innermost last):
  File "/usr/sbin/neat", line 1210, in ?
    gtk.mainloop()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2608, in 
mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/libglade.py", line 28, in 
__call__
    ret = apply(self.func, a)
  File "/usr/sbin/neat", line 401, in on_okButton_clicked
    if self.save() != 0:
  File "/usr/sbin/neat", line 271, in save
    self.saveHardware()
  File "/usr/sbin/neat", line 283, in saveHardware
    hardwarelist.save()
  File "/usr/sbin/../share/redhat-config-
network/netconfpkg/NCHardwareList.py", line 276, in save
    modules.write()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/Conf.py", 
line 981, in write
    self[key] = self.vars[key]
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/Conf.py", 
line 936, in __setitem__
    replace = key + ' ' + varname + ' ' + endofline
TypeError: illegal argument type for built-in operation

Local variables in innermost frame:
endofline: None
value: {'alias': None}
self: <netconfpkg.NCHardwareList.MyConfModules instance at 8450340>
varname: eth2
missing: 1
key: alias
place: 0
findexp: [	 ]*alias[	 ]+eth2[	 ]+
Comment 2 Harald Hoyer 2003-11-25 09:18:26 EST
hmm... this looks like an old bug. Do you really have Red Hat Linux 8?
which version of redhat-config-network is this?
$ rpm -q redhat-config-network
gives you the version.

You may also try this, if you have 7.x:
http://rhn.redhat.com/errata/RHBA-2002-267.html
Comment 3 Bart Wahlgren 2003-12-03 15:15:58 EST
Version of redhat-config is 0.9.10.2.1
OS version using uname -a is 2.4.9-e.3smp

I've been able to correct the problem by removing and reinstalling 
the NIC's. Thanks for the link I'll update the utility.

Note You need to log in before you can comment on or make changes to this bug.