Bug 110274 - php source rpm doesn't compile
php source rpm doesn't compile
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: php (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-17 14:50 EST by Nathan G. Grennan
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: 4.3.4-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-05 09:10:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch against php-4.3.3-6 spec file (996 bytes, patch)
2003-11-28 08:35 EST, Jan Visser
no flags Details | Diff

  None (edit)
Description Nathan G. Grennan 2003-11-17 14:50:23 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5)
Gecko/20031016 Galeon/1.3.10

Description of problem:
The php source doesn't compile.

Not enough of /Zend gets copied into /build-cgi/Zend and
/build-apache/Zend

Below is an example of /build-cgi/Zend:

/bin/sh /usr/src/redhat/BUILD/php-4.3.4/build-cgi/libtool --silent
--preserve-dup-deps --mode=compile gcc  -IZend/
-I/usr/src/redhat/BUILD/php-4.3.4/Zend/ -DPHP_ATOM_INC
-I/usr/src/redhat/BUILD/php-4.3.4/build-cgi/include
-I/usr/src/redhat/BUILD/php-4.3.4/build-cgi/main
-I/usr/src/redhat/BUILD/php-4.3.4
-I/usr/src/redhat/BUILD/php-4.3.4/build-cgi/Zend
-I/usr/kerberos/include -I/usr/include/libxml2
-I/usr/include/freetype2 -I/usr/include/imap
-I/usr/src/redhat/BUILD/php-4.3.4/ext/mbstring/mbregex
-I/usr/src/redhat/BUILD/php-4.3.4/ext/mbstring/libmbfl
-I/usr/src/redhat/BUILD/php-4.3.4/ext/mbstring/libmbfl/mbfl
-I/usr/include/mysql -I/usr/include/pspell
-I/usr/src/redhat/BUILD/php-4.3.4/main
-I/usr/src/redhat/BUILD/php-4.3.4/Zend
-I/usr/src/redhat/BUILD/php-4.3.4/TSRM 
-I/usr/src/redhat/BUILD/php-4.3.4/build-cgi/TSRM  -O2 -g -pipe
-march=i386 -mcpu=i686 -Wall -fno-strict-aliasing
-I/usr/kerberos/include  -prefer-non-pic -c
Zend/zend_language_scanner.c -o Zend/zend_language_scanner.o
gcc: Zend/zend_language_scanner.c: No such file or directory
gcc: no input files
make: *** [Zend/zend_language_scanner.lo] Error 1


Version-Release number of selected component (if applicable):
php-4.3.4-1.1

How reproducible:
Always

Steps to Reproduce:
1. rpm -i php-4.3.4-1.1.src.rpm
2. cd /usr/src/redhat/SPECS
3. rpmbuild -bb php.spec
    

Actual Results:  Doesn't finish compiling

Expected Results:  For it to finish compiling

Additional info:

Same problem with php-4.3.3-6.
Comment 1 Joe Orton 2003-11-18 05:46:21 EST
I can't reproduce this here on an FC1 system.  What versions of
autoconf and libtool are you running?
Comment 2 Nathan G. Grennan 2003-11-18 10:18:46 EST
libtool-1.5-8
autoconf-2.57-3

Both built by Red Hat. I do note that autoconf doesn't seem to have
been upgraded since the version is the exact same from RH9, and the
Build date is Fri 24 Jan 2003 02:01:48 PM PST.
Comment 3 Jan Visser 2003-11-28 08:33:27 EST
The fix to this problem is attached.

The problem was found in the workaround for the bug in bison-1.875-2

It does not copy the zend *scanner* files.
Comment 4 Jan Visser 2003-11-28 08:35:07 EST
Created attachment 96235 [details]
patch against php-4.3.3-6 spec file
Comment 5 Joe Orton 2003-12-01 06:22:45 EST
Thanks for the patch Jan! I've added this for 4.3.4-2 in Raw Hide.

Note You need to log in before you can comment on or make changes to this bug.