Bug 110285 - Unhandled exception when assigning partitions to LVM
Unhandled exception when assigning partitions to LVM
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: anaconda (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-17 17:15 EST by Mark Eackloff
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-12 11:24:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
One of two files created by the anaconda "Unhandled Exception" routine. (8.10 KB, text/plain)
2003-11-17 17:54 EST, Mark Eackloff
no flags Details
One of two files created by the anaconda "Unhandled Exception" routine. (292.57 KB, text/plain)
2003-11-17 17:58 EST, Mark Eackloff
no flags Details

  None (edit)
Description Mark Eackloff 2003-11-17 17:15:21 EST
escription of problem:
Proceding with installation after having created LVM group, unhandled
exception occurs.


Version-Release number of selected component (if applicable):
9.1-8.RHEL.i386

How reproducible:
Using disk druid, assign partitions on two physically separate drives
to a LVM volume.

Steps to Reproduce:
1.  Begin new install until formatting drives is required.
2.  Use Disk Druid for assign partitions on two separate drives to a 
  LVM volume.
3.  Proceed with installation.  Before "Preparing to install" comes
up, "Unhandled Exception" occurs asking to put a floppy in the drive
for submission to Bugzilla.
  
Actual results:
Unhandled Exception.

Expected results:
Formatting of the drives and the rest of the installation.

Additional info:
Comment 1 Jeremy Katz 2003-11-17 17:21:08 EST
Can you attach the dump information?
Comment 2 Mark Eackloff 2003-11-17 17:54:52 EST
Created attachment 96033 [details]
One of two files created by the anaconda "Unhandled Exception" routine.
Comment 3 Mark Eackloff 2003-11-17 17:58:28 EST
Created attachment 96034 [details]
One of two files created by the anaconda "Unhandled Exception" routine.
Comment 4 Jeremy Katz 2003-11-24 17:30:29 EST
Did you somehow try to create two volume groups named the same thing?
 Or did you have a volume group by that name before beginning the install?
Comment 5 Mark Eackloff 2003-11-25 21:53:56 EST
No.  At least the first time around.  (I tried this twice.)  It's hard
to say what may have been left over from the first attempt.  But the
first attempt was on drives left over from a RHL9 installation when I
had not used LVM.  To make sure you understand, the two partitions
were on separate drives.  But I was trying to assign them to the same
logical volume.
Comment 6 Jeremy Katz 2003-12-16 18:39:13 EST
Did you go back and forth into partitioning a couple of times?  I'm
trying to track down what happened based on the amount of logging
that's done here.  Can you provide the set of steps you used to get
this to occur?  Did you ever go beyond the partitioning screen before
starting to go back?
Comment 7 Mark Eackloff 2003-12-29 22:20:59 EST
At this point I am probably not much help in remembering exactly what
happened in what sequence.  At that time I just went around the
problem by not using LVM.

But since your 2003-13-16 post I decided I needed to try to reproduce
this on the same machine.  I don't have a tape drive so the backup was
somewhat of a pain using Zip and CD-RW media.  This time the install
went fine.  Two physical volumes on sda and two on sdb.  One volume
group.  But the re-install refreshed my memory a little.

My first attempt in November failed during the actual formatting
operation after the selecting packages and just before the packages
start loading.  The progress bar ("Formatting . . . .") stopped.  No
sounds of disk activity.  After about 15 minutes I tried breaking out
of it (don't remember how) only to find that the keyboard and mouse
were completely unresponsive.  Also, the NumLock and ScrollLock LEDs
on the keyboard were flashing.  Forced a reboot by hitting the reset
button on the box.

On my second attempt when I got to Disk Druid it appeared my
partitions were already set up as phsical volumes but I was unable to
assign mount points to the volumes.  I got some error message that I
don't remember.  I think I backed up to Disk Druid to delete the
partitions but it would not let me.  So I backed up further and used
fdisk from the shell to delete all partitions.  Returned to the gui
and continued used Disk Druid again to set up my volumes.  This is to
the best of my recollection but I couldn't swear to it.  The rest of
the story picks up step #3 in my original post.

The current status is that I've got my volume group working fine. 
Since I can't remember exactly what happened and since my volume group
is working and since I can't reproduce the problem, I wouldn't persue
this further unless other people are having the same problem.
Comment 8 Jeremy Katz 2004-02-12 11:24:17 EST
I haven't been able to reproduce this either.  If you see it again,
please reopen with better details on how you hit it.

Note You need to log in before you can comment on or make changes to this bug.