Bug 110287 - evolution missing components following error
Summary: evolution missing components following error
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
(Show other bugs)
Version: 1
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Dave Malcolm
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-11-17 22:22 UTC by Clif
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-30 05:46:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Scrennshot of Evolution error (14.43 KB, image/png)
2004-05-25 15:37 UTC, Andrew Rechenberg
no flags Details
Patch to spec file to add /usr/lib/evolution/1.4 to ld.so.conf (1.24 KB, patch)
2004-06-14 21:51 UTC, Andrew Rechenberg
no flags Details | Diff

Description Clif 2003-11-17 22:22:36 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031030 MultiZilla/1.5.0.3o

Description of problem:
Whenever I start evolution I get the following error:
Cannot activate component
OAFIID:GNOME_Evolution_ExchangeStorage_ShellComponent :
The error from the activation system is:
Child process did not give an error message, unknown failure occurred

Following that:
  - default shortcuts don't work, those that I've created are missing
  - there's no way to access my exchange server via connector - no
folder, shortcut, etc.

This bug looks identical to bug 101069 which is listed as being fixed
for severn.

Thanks, Clif

Version-Release number of selected component (if applicable):
1.4.5-7

How reproducible:
Always

Steps to Reproduce:
1.  start evolution
2.  read error
3.  see missing components
    

Actual Results:  Cannot activate component
OAFIID:GNOME_Evolution_ExchangeStorage_ShellComponent :
The error from the activation system is:
Child process did not give an error message, unknown failure occurred

Additional info:

Comment 1 Dave Malcolm 2004-05-18 01:17:27 UTC
Which version of the Connector are you running?  How did obtain the code?

I've put up a test version of the connector for FC2 at
http://people.redhat.com/dmalcolm/evo-1-4-connector

I can do packages for FC1 if that would be helpful.

Comment 2 Andrew Rechenberg 2004-05-25 15:35:34 UTC
I created an RPM for FC1 from the SRPM package at
http://people.redhat.com/tcallawa/evolution-connector/ and I am
experiencing this same error.  I am using
evolution-connector-1.4.7-1.i386.rpm.

Comment 3 Andrew Rechenberg 2004-05-25 15:37:51 UTC
Created attachment 100542 [details]
Scrennshot of Evolution error

Comment 4 Alan Schmidt 2004-05-28 03:39:16 UTC
I'm using the yum repository at  
  
http://people.redhat.com/dmalcolm/evo-1-4-connector/  
  
and I have identical results. When I run  
  
/usr/libexec/evolution/1.4/evolution-exchange-storage  
  
by hand, I get  
  
/usr/libexec/evolution/1.4/evolution-exchange-storage: error while  
loading shared libraries: libeshell.so.0: cannot open shared object  
file: No such file or directory  
  
however, I see libeshshell.so.0 in /usr/lib/evolution/1.4  
  
If I add /usr/lib/evolution/1.4 to /etc/ld.so.conf, run ldconfig, and 
then killev the error goes away. 

Comment 5 Bryan Christ 2004-06-14 21:30:48 UTC
I am having the same problem.  I have installed Connector from the URL
listed at http://people.redhat.com/dmalcolm/evo-1-4-connector/ also. 
I have found that re-installing the rpm (--install --force) will make
it work again.  However, after you close Evolution down, the problem
will start all over again. 

Comment 6 Andrew Rechenberg 2004-06-14 21:50:32 UTC
I've modified the spec file for the SRPM at
http://people.redhat.com/tcallawa/evolution-connector/ to add
/usr/lib/evolution/1.4 to /etc/ld.so.conf and remove it upon
uninstall.  I'll attach a diff of the spec file

Comment 7 Andrew Rechenberg 2004-06-14 21:51:33 UTC
Created attachment 101128 [details]
Patch to spec file to add /usr/lib/evolution/1.4 to ld.so.conf

Comment 8 Eugene Roux 2004-06-17 05:17:19 UTC
I would seem like the problem is caused by evolution-exchange-storage
still running when you try to start up evolution again.

Evolution seems to attempt to restart the component, and failing to do
that barfs.

Doing a:

kill `ps -ef| grep evolution-exchange-storage| grep -v grep| awk
'{print $2}'`

before attemting to re-start evolution seems to allow evolution to
start fine and seems to allow access to the Exchange server without a
problem.

Comment 9 Dave Malcolm 2004-06-25 21:23:19 UTC
I've uploaded a new version of the connector to
http://people.redhat.com/tcallawa/evolution-connector/
(1.4.7-5)

This should fix these problems


Comment 10 Dave Malcolm 2004-11-30 05:46:22 UTC
I believe this has been fixed for a while now, so closing as
CURRENTRELEASE


Note You need to log in before you can comment on or make changes to this bug.