Bug 110292 - libgcj-ssa Process.waitFor is incorrect
libgcj-ssa Process.waitFor is incorrect
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: gcc (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tom Tromey
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-17 18:48 EST by Tom Tromey
Modified: 2014-08-11 01:46 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-16 14:52:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tom Tromey 2003-11-17 18:48:15 EST
The libgcj-ssa Process.waitFor method is incorrect.
Currently we only reap child processes if waitFor is called.
However, this is not required by the Process contract.
This means that, eg, eclipse leaves zombie children around.

This is also in the upstream gcc bugzilla:

http://gcc.gnu.org/bugzilla/show_bug.cgi?id=11801

I'm submitting this here as well since we need to track
it locally; we need this fixed more urgently than does
gcc.gnu.org.
Comment 1 Bryce McKinlay 2005-03-16 14:52:06 EST
Fixed in GCC 4.0 by a new implementation of java.lang.Process. The fix is in GCC
4, so I'm closing this bug.

Note You need to log in before you can comment on or make changes to this bug.