Bug 11031 - passwd fails on "*"
Summary: passwd fails on "*"
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: passwd   
(Show other bugs)
Version: 6.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-04-25 13:41 UTC by gerald
Modified: 2013-07-02 22:54 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-06 13:20:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description gerald 2000-04-25 13:41:15 UTC
passwd fails to change the password of accounts which have a single

"*" as password entry (no shadow passwords used).



It claimes that it has changed the password, but in reality it does

nothing.

Comment 1 Cristian Gafton 2000-05-22 15:36:59 UTC
assigned to nalin

Comment 2 gerald 2000-05-23 07:54:59 UTC
BTW, in addition I noticed that passwd only checks UID (and not EUID) for

permissions, so if passwd is called from a suid root script, it will fail....



Gerald

Comment 3 Jindrich Novy 2004-09-06 13:20:40 UTC
I tested it and it works for me with passwd-0.68. Closing this.

Jindrich


Note You need to log in before you can comment on or make changes to this bug.