Bug 11032 - Cron pretending to execute jobs
Summary: Cron pretending to execute jobs
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: vixie-cron   
(Show other bugs)
Version: 6.2
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Crutcher Dunnavant
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-04-25 13:43 UTC by rossigee
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-10 22:01:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description rossigee 2000-04-25 13:43:27 UTC
I noticed that all my scheduled jobs stopped working after upgrading my
gateway machine to RH61. As I only have a handful of non-critical jobs on
this machine, I've never worried about it too much.

Cron is running, and making log entries as expected, but when I check to
see that the job has been done - it hasn't. After restarting cron, it runs
each job once, then never again.

I upgraded to vixie-cron-3.0.1-40 (from 6.2), but nothing changed. Upgraded
again to vixie-cron-3.0.1-42 (Rawhide), and still it's broken.

Here's the problem:

[root@shiva log]# rpm -q vixie-cron
vixie-cron-3.0.1-42
[root@shiva log]# ps aux | grep cron
root      9212  0.0  1.5  1516  712 ?        S    14:11   0:00 crond
[root@shiva log]# grep touch /etc/crontab
* * * * * root touch /tmp/check-crontab
[root@shiva log]# date
Tue Apr 25 14:18:33 BST 2000
[root@shiva log]# grep check-crontab /var/log/cron | tail -3
root (04/25-14:16:00-9740) CMD (touch /tmp/check-crontab)
root (04/25-14:17:00-9780) CMD (touch /tmp/check-crontab)
root (04/25-14:18:00-9806) CMD (touch /tmp/check-crontab)
[root@shiva log]# date
Tue Apr 25 14:36:24 BST 2000
[root@shiva log]# ls -l /tmp/check-crontab
-rw-rw-r--   1 root     root            0 Apr 25 14:12 /tmp/check-crontab
[root@shiva log]# /etc/rc.d/init.d/crond restart
Stopping cron daemon:                                      [  OK  ]
Starting cron daemon:                                      [  OK  ]
[root@shiva log]# date
Tue Apr 25 14:40:39 BST 2000
[root@shiva log]# ls -l /tmp/check-crontab
-rw-rw-r--   1 root     root            0 Apr 25 14:37 /tmp/check-crontab

I am also running nss_ldap and openldap on this machine (all else works
fine). No ORPHAN messages. I have other machines running the same
combination that work fine (hard to reproduce).

No zombie processes or anything, it just makes a log entry but then doesn't
do the job.

Any ideas what might be happening?

Comment 1 rossigee 2000-04-26 22:16:59 UTC
This has been resolved this now.

I upgraded all my stock RH61 packages on the machine to their RH62 equivalents,
so I am unable to determine exactly which component was the cause of the
problem, but at least it can be resolved by using a current release.


Note You need to log in before you can comment on or make changes to this bug.