Bug 1103239 - warning during using mock
Summary: warning during using mock
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: mock
Version: epel7
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
Assignee: Miroslav Suchý
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-05-30 14:08 UTC by Levente Farkas
Modified: 2014-10-10 16:04 UTC (History)
11 users (show)

Fixed In Version: mock-1.1.41-3.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-20 03:24:30 UTC
Type: Bug


Attachments (Terms of Use)

Description Levente Farkas 2014-05-30 14:08:39 UTC
i've got this on screen each time i build an src.rpm:

No handlers could be found for logger "trace.__main__"

Comment 1 Simone Caronni 2014-06-02 08:08:59 UTC
Also happens on Fedora every time:

$ rpm -qa mock\*
mock-1.1.39-1.fc20.noarch
mock-scm-1.1.39-1.fc20.noarch

Comment 2 Miroslav Suchý 2014-06-02 08:26:04 UTC
Can you please post exact command, which cause this?
Because this:
  mock -r fedora-20-x86_64 mock-1.1.39-1.el6.src.rpm
works for me (on F20).

Comment 3 Simone Caronni 2014-06-02 08:27:32 UTC
Some examples:

mock -r fedora-20-x86_64 --rebuild mock-1.1.39-1.el6.src.rpm
mock -r fedora-20-x86_64 --rebuild --no-clean --offline mock-1.1.39-1.el6.src.rpm

Comment 4 Miroslav Suchý 2014-06-03 11:21:40 UTC
Note for myself:
Introduced by commit cd3c76d93d228adc2e1b9b871a2c14995503718d

Comment 5 Miroslav Suchý 2014-06-09 08:42:23 UTC
For people in Cc: This warning is harmless and can be safely ignored (therefore lowering severity).
While naive approach can be reverting cd3c76d, this is not correct. It may show some bug in python (and logging module). I contacted python team with minimal reproducer and we are investigating what is really happening. But it may take some time.

Comment 6 Tom Hughes 2014-06-09 08:44:18 UTC
It may be harmless, but it's filling up my mailbox with junk every night when my mock using cron jobs run ;-)

Comment 7 Antonio T. (sagitter) 2014-07-01 16:37:39 UTC
(In reply to Miroslav Suchý from comment #2)
> Can you please post exact command, which cause this?
> Because this:
>   mock -r fedora-20-x86_64 mock-1.1.39-1.el6.src.rpm
> works for me (on F20).

It appears with fedora-review for me.

$ rpm -qa | grep -e fedora-review -e mock
python-flexmock-0.9.6-3.fc20.noarch
python-mock-1.0.1-2.fc20.noarch
mock-1.1.39-1.fc20.noarch
fedora-review-0.5.1-2.fc20.noarch
fedora-review-plugin-java-3.4.1-1.fc20.noarch

Comment 8 Miroslav Suchý 2014-07-08 06:15:43 UTC
Temporary reverted in commit af26950
But for me this is not proper fix. I will leave this BZ, but in next release this warning should not appear.

Comment 9 Fedora Update System 2014-07-18 02:13:16 UTC
mock-1.1.40-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/mock-1.1.40-2.fc20

Comment 10 Fedora Update System 2014-07-18 02:13:42 UTC
mock-1.1.40-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/mock-1.1.40-2.fc19

Comment 11 Fedora Update System 2014-07-18 02:14:05 UTC
mock-1.1.40-2.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/mock-1.1.40-2.el6

Comment 12 Fedora Update System 2014-07-18 17:45:22 UTC
mock-1.1.41-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/mock-1.1.41-1.fc20

Comment 13 Fedora Update System 2014-07-18 17:45:50 UTC
mock-1.1.41-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/mock-1.1.41-1.fc19

Comment 14 Fedora Update System 2014-07-18 17:46:15 UTC
mock-1.1.41-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/mock-1.1.41-1.el6

Comment 15 Fedora Update System 2014-07-19 05:58:04 UTC
Package mock-1.1.41-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mock-1.1.41-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-8492/mock-1.1.41-1.fc20
then log in and leave karma (feedback).

Comment 16 Fedora Update System 2014-07-20 03:24:30 UTC
mock-1.1.41-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2014-07-22 18:07:50 UTC
mock-1.1.41-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2014-09-16 16:46:50 UTC
mock-1.1.41-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/mock-1.1.41-2.fc19

Comment 19 Fedora Update System 2014-09-30 09:00:05 UTC
mock-1.1.41-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/mock-1.1.41-3.fc19

Comment 20 Fedora Update System 2014-10-10 16:04:12 UTC
mock-1.1.41-3.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.