Bug 1103354 - pulp.server.managers.event.remote requires qpid.messaging
Summary: pulp.server.managers.event.remote requires qpid.messaging
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Pulp
Classification: Retired
Component: API/integration
Version: Master
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
: ---
Assignee: pulp-bugs
QA Contact: pulp-qe-list
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-05-30 19:45 UTC by Randy Barlow
Modified: 2015-02-28 22:09 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-28 22:09:29 UTC


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Pulp Redmine 443 0 None None None Never

Description Randy Barlow 2014-05-30 19:45:54 UTC
I noticed today that pulp.server.managers.event.remote has these two import statements:

 16 from qpid.messaging import Connection
 17 from qpid.messaging.exceptions import ConnectionError, MessagingError

I believe we should strive to be message broker agnostic as an upstream project, so we should not require qpid.messaging. Here are two suggested fixes:

1) It has been proposed that we could simply remove the feature provided by this module. It may not be very useful, especially since users can now monitor Celery tasks.

2) We could rework this module to use Kombu for message broker abstraction.

I would like to suggest that we make this low priority on 2.4. It's not a regression, since we didn't support rabbitmq in 2.3. It would be nice though since we are trying to allow users to choose rabbitmq for 2.4.

Comment 1 Randy Barlow 2014-11-20 13:26:49 UTC
I think this one is more of a defect than a task, since it is the only element of Pulp that actually does require a Qpid dependency. For Rabbit users this would be annoying.

It could be argued as a feature too I suppose since it's about supporting Rabbit with our event system.

Comment 2 Brian Bouterse 2015-02-28 22:09:29 UTC
Moved to https://pulp.plan.io/issues/443


Note You need to log in before you can comment on or make changes to this bug.