Bug 110347 - bad wvdial.config plus modem status not displayed
Summary: bad wvdial.config plus modem status not displayed
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: redhat-config-network
Version: 1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 111252
TreeView+ depends on / blocked
 
Reported: 2003-11-18 18:06 UTC by Ed
Modified: 2007-11-30 22:10 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2003-12-17 14:01:24 UTC


Attachments (Terms of Use)

Description Ed 2003-11-18 18:06:39 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6b)
Gecko/20031114 Firebird/0.7+

Description of problem:
I installed fedora yesterday and used r-c-n to set up the numbers for
my ISP. I was unable to dial out and the tones sounded 'odd'. When I
looked at /etc/wvdial.conf it appeared to contain two errors compared
to the one I'd archived from RH9. Below is the top of that file:

[Modem0]
Modem = /dev/modem
Baud = 115200
SetVolume = 1
Dial Command = ATDT
Init1 = ATZ
Init3 = ATM1L1
FlowControl = Hardware (CRTSCTS)

The flow control line is bad it should read
FlowControl = CRTSCTS

also the original Init3 was ATM1

It is possible (likely) that I hadn't tried to edit the modem hardware
prior to use so it inherited a poor default.

Having fixed these, the modem works. However, when I use r-c-n to
activate the connection the status is not updated, this makes it
impossible to deactivate the connection.

Ed

Version-Release number of selected component (if applicable):
redhat-config-network-1.3.10-1

How reproducible:
Always

Steps to Reproduce:
Haven't tried to reproduce bad wvdial.conf yet. For poor status follwo
steps above.
1.
2.
3.
    

Actual Results:  as above

Expected Results:  I'd expect r-c-n to dispaly modem as active when it
was active.

Additional info:


Note You need to log in before you can comment on or make changes to this bug.