Bug 11035 - chkfontpath needs prereq of popt
chkfontpath needs prereq of popt
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: chkfontpath (Show other bugs)
6.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-04-25 12:23 EDT by Matthew Miller
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-24 23:42:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Miller 2000-04-25 12:23:00 EDT
The chkfontpath program requires popt to run. Unfortunately, it currently
only has an autodependency, when it really needs a prereq.

The current requirement doesn't guarantee that libpopt will be installed
when chkfontpath is -- only that it will get installed in the same package
set. This is a problem if font packages requiring chkfontpath get installed
at the same time -- sometimes the order ends up like this:

 chkfontpath
 fontpackage
 popt

When this happens, the post install script for the font package won't work
right, because chkfontpath can't run.
Comment 1 Preston Brown 2000-06-26 15:50:42 EDT
fixed in rawhide.
Comment 2 Matthew Miller 2001-08-24 23:39:28 EDT
This was marked fixed in rawhide long ago, but roswell2 public beta still
doesn't contain "Prereq: popt". It does have prereq XFree86-xfs and /sbin/pidof,
but I think it needs popt too, unless something has changed in the way anaconda
does its ordering that I don't understand.

As I understand it, when a set of packages gets all installed at once,
"required" only insures that all deps will be met after the dust settles. In
order to influence ordering within that set, one needs prereq. The problem here
is that some packages need chkfontpath to run properly to be installed, and if
popt isn't there first, there will be trouble....

Or, is popt now a prereq for all packages for which chkfontpath is?

If I'm all confused about this, feel free to tell me. :)
Comment 3 Bill Nottingham 2001-08-25 00:33:52 EDT
See mail. :)

Note You need to log in before you can comment on or make changes to this bug.