Bug 1103528 - Right click does not work on Dell Vostro 5470
Summary: Right click does not work on Dell Vostro 5470
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 20
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
Hans de Goede
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-06-01 16:47 UTC by Elder Marco
Modified: 2015-04-22 19:51 UTC (History)
10 users (show)

Fixed In Version: kernel-3.14.7-100.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-13 22:49:39 UTC


Attachments (Terms of Use)
dmesg (82.43 KB, text/plain)
2014-06-01 16:47 UTC, Elder Marco
no flags Details
Xorg.0.log (67.19 KB, text/x-log)
2014-06-01 16:49 UTC, Elder Marco
no flags Details
evemu.log (17.25 KB, text/x-log)
2014-06-01 17:02 UTC, Elder Marco
no flags Details
elantech-right-click-fw_361f05.patch (1.53 KB, patch)
2014-06-04 20:26 UTC, Elder Marco
no flags Details | Diff
[PATCH] elantech: Deal with clickpads reporting right button events (3.01 KB, patch)
2014-06-05 10:00 UTC, Hans de Goede
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1030802 None None None Never

Description Elder Marco 2014-06-01 16:47:44 UTC
Created attachment 901260 [details]
dmesg

Description of problem:

I'm using fedora 20 on Dell Vostro 5470. The touchpad works fine, except for the right key. This right key is not working at all.

Version-Release number of selected component (if applicable):
kernel-3.14.4-200.fc20.x86_64


How reproducible:
Always


Steps to Reproduce:
1. Install fedora 20 on dell vostro 5470
2. Update (or not) you system
3.

Actual results:
right key does not work

Expected results:
Right key works normally.

Additional info:

xev output:

ButtonPress event, serial 34, synthetic NO, window 0x1600001,
    root 0xbd, subw 0x1600002, time 8131538, (35,47), root:(36,107),
    state 0x0, button 1, same_screen YES

EnterNotify event, serial 34, synthetic NO, window 0x1600001,
    root 0xbd, subw 0x0, time 8131411, (35,47), root:(36,107),
    mode NotifyGrab, detail NotifyInferior, same_screen YES,
    focus YES, state 256

KeymapNotify event, serial 34, synthetic NO, window 0x0,
    keys:  4294967229 0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   
           0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   

ButtonRelease event, serial 34, synthetic NO, window 0x1600001,
    root 0xbd, subw 0x1600002, time 8131679, (35,47), root:(36,107),
    state 0x100, button 1, same_screen YES

LeaveNotify event, serial 34, synthetic NO, window 0x1600001,
    root 0xbd, subw 0x0, time 8131662, (35,47), root:(36,107),
    mode NotifyUngrab, detail NotifyInferior, same_screen YES,
    focus YES, state 0

When I right click, xev register nothing.

Comment 1 Elder Marco 2014-06-01 16:49:21 UTC
Created attachment 901261 [details]
Xorg.0.log

Comment 2 Elder Marco 2014-06-01 17:02:55 UTC
Created attachment 901262 [details]
evemu.log

I pressed the left key first. After that, the right key and then, the right and the left key at the same time.

Comment 3 Elder Marco 2014-06-04 20:26:59 UTC
Created attachment 902326 [details]
elantech-right-click-fw_361f05.patch

I'm not a programmer, but the attached patch adds an exception and fix the problem. Works fine here.

Comment 4 Hans de Goede 2014-06-05 09:59:39 UTC
Hi Elder,

Thanks for reporting this and thanks for the patch. It is also great that you've added an evemu-record log, very useful!

Looking at: http://www.dell.com/ed/business/p/vostro-5470/pd your laptop really does have a clickpad, so it is weird that it actually reports right clicks for the right bottom area, no other elantech clickpad does this.

Even though it reports right clicks, otherwise your clickpad does still very much behave as a clickpad, ie it reports finer movements in the bottom area, which can typically lead to mis-clicks due to the pointer moving slightly before the click, or to a click being wrongly seen as a click + drag.

Thus I would like to keep reporting these devices as clickpads to userspace, so that userspace can filter out touches starting in the bottom area (you can still use the entire pad to move around if a touch starts outside the bottom area).

I've created a slightly different patch which should also fix your problem, while it keeps reporting your touchpad as a clickpad to userspace. I'll attach the patch here, can you please build a kernel with this patch, and give it a test ?

Thanks & Regards,

Hans

Comment 5 Hans de Goede 2014-06-05 10:00:25 UTC
Created attachment 902474 [details]
[PATCH] elantech: Deal with clickpads reporting right button events

Comment 6 Elder Marco 2014-06-05 21:22:32 UTC
Hi  Hans,

Yes, the patch fix my problem! Thank you very much!

And you are right, it looks like the Dell Vostro 5470 has two separate buttons under the pad. But the right click only work if I click a little more strongly on the bottom right. Otherwise, the pad reports a left click.

Comment 7 Hans de Goede 2014-06-06 14:10:38 UTC
(In reply to Elder Marco from comment #6)
> Hi  Hans,
> 
> Yes, the patch fix my problem! Thank you very much!

That is good to hear. I've send the patch upstream. If it gets a positive review there I'll also add it to the Fedora kernels.

> And you are right, it looks like the Dell Vostro 5470 has two separate
> buttons under the pad. But the right click only work if I click a little
> more strongly on the bottom right. Otherwise, the pad reports a left click.

I assume the above is no longer true with my patch ? Since with my patch it does not matter which of the 2 buttons gets triggered, as long as the finger doing the clicking is in the bottom right area, correct ?

Regards,

Hans

Comment 8 Hans de Goede 2014-06-06 14:19:46 UTC
In hindsight, I really have too much on my todo list and need to put my priorities elsewhere, sorry.

Josh, can you add the attached patch to the Fedora kernel builds and then close this bug please ?

Comment 9 Elder Marco 2014-06-06 15:47:32 UTC
No, it's true. And it is a strange behavior, I know. The bottom right area acts as a left button if I click more slightly  (not pressing the button under the pad), but acts like a right button if I click more strongly, that is, I get a right click If I press the button under the pad). It's also occurs with the patch that I have attached. Is this right?


Thank you! No problem.

Comment 10 Hans de Goede 2014-06-07 09:08:24 UTC
(In reply to Elder Marco from comment #9)
> No, it's true. And it is a strange behavior, I know. The bottom right area
> acts as a left button if I click more slightly  (not pressing the button
> under the pad), but acts like a right button if I click more strongly, that
> is, I get a right click If I press the button under the pad). It's also
> occurs with the patch that I have attached. Is this right?

Ah I see, yes this is right soft clicks (so a click which does not trigger the button under the  pad) are called taps and a single finger tap always  emulates a left button click. For a right click using tapping use a 2 finger tap.

Regards,

Hans

Comment 11 Elder Marco 2014-06-07 13:28:43 UTC
Hehe,thanks. First time using a clickpad... :)

Solved! Waiting for the kernel update.

Comment 12 Josh Boyer 2014-06-11 20:43:22 UTC
Patch applied.  Thanks Hans.

Comment 13 Fedora Update System 2014-06-12 12:13:47 UTC
kernel-3.14.7-200.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/kernel-3.14.7-200.fc20

Comment 14 Fedora Update System 2014-06-12 12:15:43 UTC
kernel-3.14.7-100.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/kernel-3.14.7-100.fc19

Comment 15 Fedora Update System 2014-06-13 05:26:44 UTC
Package kernel-3.14.7-200.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.14.7-200.fc20'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-7313/kernel-3.14.7-200.fc20
then log in and leave karma (feedback).

Comment 16 Fedora Update System 2014-06-13 22:49:39 UTC
kernel-3.14.7-200.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2014-06-16 23:28:56 UTC
kernel-3.14.7-100.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 18 Gabriel 2015-04-22 19:31:53 UTC
This bug is back on fedora 22 kernel 4.0.0-0.rc5.git4.1.fc22.x86_64

Comment 19 Josh Boyer 2015-04-22 19:39:13 UTC
(In reply to Gabriel from comment #18)
> This bug is back on fedora 22 kernel 4.0.0-0.rc5.git4.1.fc22.x86_64

Please update to 4.0.0-1.fc22 and open a new bug if it is still present.

Comment 20 Gabriel 2015-04-22 19:51:44 UTC
Ok.. bug created: 1214477.

Thanks.


Note You need to log in before you can comment on or make changes to this bug.