Bug 1103747 - Unable to list all Queues/Topics (from "Profiles" tab) in Management Console for EAP 6.x
Summary: Unable to list all Queues/Topics (from "Profiles" tab) in Management Console ...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Web Console
Version: 6.2.2
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ER6
: EAP 6.3.0
Assignee: Harald Pehl
QA Contact: Jakub Cechacek
Russell Dickenson
URL:
Whiteboard:
Keywords:
Depends On: 1104216
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-06-02 13:00 UTC by Amana
Modified: 2018-12-05 18:45 UTC (History)
10 users (show)

(edit)
In previous versions of JBoss EAP 6, users found they could not list all topics and/or queues under the profiles tab in the Management Console. The maximum number of queues that was visible was eight. This has been addressed in this release and now all queues are visible.
Clone Of:
(edit)
Last Closed: 2014-06-28 15:25:48 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 904023 None None None Never
JBoss Issue Tracker HAL-411 Major Resolved Unable to list all Queues/Topics 2017-03-30 20:53 UTC

Description Amana 2014-06-02 13:00:31 UTC
Description of problem:

It is not possible to list all Queues/Topics under "Profiles" tab in the Management Console for EAP 6.x. Management Console lists eight Queues/Topics at most, but CLI lists 15 Queues. 

Version-Release number of selected component (if applicable):

It seems like it is an issue since EAP 6.0.x, but customer reproduced it on EAP 6.2.2.

How reproducible:

Generate more than eight queues and try to list them under "Profiles" tab in Management Console.


Actual results:

You will be able to view only eight Queues.

Expected results:

It should list all existing Queues.

Additional info:

As a workaround you can use CLI or even list it from "Runtime" tab in Management Console.

Comment 6 Rostislav Svoboda 2014-06-03 13:49:43 UTC
EAP 6 PM call 2014-Jun-03:
    Bug 1103747 -        Unable to list all Queues/Topics (from "Profiles" tab) in Management Console for EAP 6.x
    Agreed: Try for ER6 cutoff today, but do not block if does not make it

Comment 7 JBoss JIRA Server 2014-06-03 15:00:43 UTC
Harald Pehl <hpehl@redhat.com> updated the status of jira HAL-411 to Resolved

Comment 8 Kabir Khan 2014-06-04 08:56:57 UTC
Fixed by https://bugzilla.redhat.com/show_bug.cgi?id=1104216

Comment 9 Jakub Cechacek 2014-06-13 06:52:10 UTC
Verified 6.3.0.ER7

Comment 10 Scott Mumford 2014-06-16 02:46:40 UTC
Hi Harald,

Would you consider this issue a Bug Fix or an Enhancement as far as the Release Notes are concerned?

Was the Management Console bugged in that it only showed 8 Queues (and was supposed to show all), or was it working as intended and it's now been enhanced to show all Queues?

Comment 11 Harald Pehl 2014-06-17 00:08:14 UTC
It's a bugfix.


Note You need to log in before you can comment on or make changes to this bug.