Bug 1103780 - Recovery with Postgres SQL Plus shows exception java.util.ConcurrentModificationException in log
Summary: Recovery with Postgres SQL Plus shows exception java.util.ConcurrentModificat...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Transaction Manager
Version: 6.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: EAP 6.4.0
Assignee: tom.jenkinson
QA Contact: Ondrej Chaloupka
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-06-02 14:21 UTC by Ondrej Chaloupka
Modified: 2017-10-10 00:22 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-19 10:31:49 UTC
Type: Bug


Attachments (Terms of Use)
JPAMultiCMRCrashRecoveryTestCase#test3CMRCrashRec_jta_server.log (1.01 MB, text/x-log)
2014-06-02 14:21 UTC, Ondrej Chaloupka
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1152782 None None None Never

Internal Links: 1152782

Description Ondrej Chaloupka 2014-06-02 14:21:01 UTC
Created attachment 901466 [details]
JPAMultiCMRCrashRecoveryTestCase#test3CMRCrashRec_jta_server.log

I'm getting the following exception in one of the crash recovery scenario when running on PostgreSQL Plus.

ERROR [stderr] (Periodic Recovery) Exception in thread "Periodic Recovery" java.util.ConcurrentModificationException
ERROR [stderr] (Periodic Recovery) at java.util.HashMap$HashIterator.nextEntry(HashMap.java:922)
ERROR [stderr] (Periodic Recovery) at java.util.HashMap$KeyIterator.next(HashMap.java:956)
ERROR [stderr] (Periodic Recovery) at com.arjuna.ats.internal.jta.recovery.arjunacore.CommitMarkableResourceRecordRecoveryModule.periodicWorkFirstPass(CommitMarkableResourceRecordRecoveryModule.java:167)
ERROR [stderr] (Periodic Recovery) at com.arjuna.ats.internal.arjuna.recovery.PeriodicRecovery.doWorkInternal(PeriodicRecovery.java:743)
ERROR [stderr] (Periodic Recovery) at com.arjuna.ats.internal.arjuna.recovery.PeriodicRecovery.run(PeriodicRecovery.java:371)

The scenario works with 3 db accounts on one DB machine.
1. 3 CMR resources + testXA resource
2. wait after prepare
3. crash server
4. reboot
5. check that CMRs are committed

The test works fine - meaning the functionality part - but the server log contains this strange exception.

Comment 3 tom.jenkinson 2014-08-18 13:02:18 UTC
Hi Ondra,

I am having trouble lining up the stack trace with the version of Narayana I have on my machine.

Please can you confirm the version?

Thanks,
Tom

Comment 4 Ondrej Chaloupka 2014-08-19 10:31:49 UTC
Hi Tom,

I tried to reproduce this and as running on 6.3.0.GA I'm free from the problematic exception as well. 

I'm sorry for promoting this to 6.4.0 as it seems that this issue disappeared, probably as some side effect, at GA and Narayana 4.17.21.Final.

If you don't mind I will close this as not a bug. In case that I will hit it again I would create new bz with better description how to reproduce.

Thank you
Ondra

Comment 5 tom.jenkinson 2014-08-19 13:22:33 UTC
Thanks Ondra, the code is synchronized but the lines don't tally up so it may be I added it later or something but before GA.

Thanks again,
Tom


Note You need to log in before you can comment on or make changes to this bug.