Bug 110381 - rfe: [patch] consider upgrading to postgresql 7.4
Summary: rfe: [patch] consider upgrading to postgresql 7.4
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: postgresql   
(Show other bugs)
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Jee
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-11-18 22:30 UTC by Kaj J. Niemi
Modified: 2007-04-18 16:59 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-01 12:28:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for SOURCES/postgresql/ (31.20 KB, patch)
2003-11-18 22:32 UTC, Kaj J. Niemi
no flags Details | Diff
Diff for postgresql.spec (6.14 KB, patch)
2003-11-18 22:34 UTC, Kaj J. Niemi
no flags Details | Diff

Description Kaj J. Niemi 2003-11-18 22:30:14 UTC
Hi,


Please accept the following patches for Postgresql 7.4
(diffs against postgresql 7.3.4-2 SRPM from Rawhide)

It builds cleanly and seems to work during light testing.

Comment 1 Kaj J. Niemi 2003-11-18 22:32:40 UTC
Created attachment 96048 [details]
Patch for SOURCES/postgresql/

Updates old patches from 7.3.4-2 to 7.4

Excluding *.jar, *.tar.gz and *.tgz files from the diff ;-)

Comment 2 Kaj J. Niemi 2003-11-18 22:34:10 UTC
Created attachment 96049 [details]
Diff for postgresql.spec

* Tue Nov 18 2003 Kaj J. Niemi <kajtzu@fi.basen.net> 7.4-0.1
									       
									       
	    - 7.4
- Fixed Patch #1 (now rpm-pgsql-7.4.patch)
- Fixed Patch #2 (now rpm-multilib-7.4.patch):
- Patch #4 is unnecessary (upstream)
- Fixed Patch #6 (now postgresql-7.4-src-tutorial.patch)
- Added Patch #8 (postgresql-7.4-com_err.patch) as com_err()
  is provided by e2fsprogs and CPPFLAGS gets lost somewhere
  inside configure (bad macro?)
- No 7.4 PDF docs available yet (Source #17)
- PyGreSQL is separated from the upstream distribution but
  we include it as usual (Source #18)
- Default to compiling libpq and ECPG as fully thread-safe

Comment 3 David Jee 2003-11-20 17:51:09 UTC
Thank you for your contribution to the Fedora project.  Upon initial
inspection, your patch looks good, except that I still see 7.3.4 docs
included.

Now, there are plans in the PostgreSQL community to do a complete
overhaul of the postgresql RPM specfile for 7.4, in order to provide a
better upgrade mechanism.  (Please refer to the following thread for
more information:
http://archives.postgresql.org/pgsql-hackers/2003-11/msg00661.php)

Since we track the community's specfile closely, we're currently
waiting for a community release of 7.4 RPMs before we release our own.
   (As a sidenote, that probably won't happen until the release of
Fedora Core 2.)  When that happens, I will consider your patch for
inclusion.  In the meanwhile, may I suggest that you send your patch
upstream? (Of course, it would have to be edited accordingly and
regenerated for the community specfile.)

Comment 4 Lamar Owen 2003-11-21 14:32:05 UTC
Upstream would be me.  Many thanks to Kaj.  While I would like to do 
the major overhaul for 7.4, that doesn't look like it will happen.  
I will look over the patches, and may release today. 

Comment 5 Lamar Owen 2003-11-21 17:53:54 UTC
Upstream RPMs for fedora core are being uploaded now to 
ftp.postgresql.org.  These are based on Kaj's work, with some 
corrections and additions.  In particular I used his reintegration 
of PygreSQL in the mix, even though it was eliminated from the 
upstream tarball.  In addition, I packaged the development jars that 
will become the 7.4 jars for JDBC. 
 
With David's announcement of the rh-postgresql stuff being added to 
the 7.3.4 set for FC1, I am considering adding this stuff upstream, 
if that is OK.  That would just be in the upstream RPM, not as part 
of the upstream tarball. 

Comment 6 Kaj J. Niemi 2004-02-01 12:28:11 UTC
I'll close this since Rawhide has 7.4 now..


Note You need to log in before you can comment on or make changes to this bug.