Bug 1103876 - [RFE] remove log collector as mandatory dependency
Summary: [RFE] remove log collector as mandatory dependency
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-installer
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.4.3
Assignee: Sandro Bonazzola
QA Contact: Pavel Stehlik
URL:
Whiteboard: integration
Depends On:
Blocks: 1301902
TreeView+ depends on / blocked
 
Reported: 2014-06-02 19:12 UTC by Alon Bar-Lev
Modified: 2016-01-26 10:21 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
: 1301902 (view as bug list)
Environment:
Last Closed: 2014-07-18 09:37:30 UTC
oVirt Team: ---
sbonazzo: ovirt_requires_release_note?


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 30051 master MERGED packaging: spec: updated tools dependencies Never
oVirt gerrit 30052 ovirt-engine-3.5 MERGED packaging: spec: updated tools dependencies Never
oVirt gerrit 30053 ovirt-engine-3.4 MERGED packaging: spec: updated tools dependencies Never
oVirt gerrit 30058 ovirt-engine-3.4.3 MERGED packaging: spec: updated tools dependencies Never
Red Hat Bugzilla 1122918 None None None Never

Internal Links: 1122918

Description Alon Bar-Lev 2014-06-02 19:12:43 UTC
I already suggested this several times within mailing list. Escalating now.

Please remove the log collector as mandatory dependency of engine. This support package was design for commercial support, I am not aware of single inside where at community it was used.

It pulls the sos dependencies and we see that it has conflicts and issues we do not need to manage at this point.

Installing this as explicitly should be still supported where possible.

Thanks.

Comment 1 Sandro Bonazzola 2014-06-27 08:56:23 UTC
re-targeting to 3.6.0 as this is a RFE, not for zstream and 3.5 is already in feature freeze.

Comment 2 Alon Bar-Lev 2014-06-27 09:09:08 UTC
(In reply to Sandro Bonazzola from comment #1)
> re-targeting to 3.6.0 as this is a RFE, not for zstream and 3.5 is already
> in feature freeze.

this has nothing to do with any freeze.
we should have removed this dependencies long ago.
nobody use it, and it only creates compatibility issues.

Comment 3 Sandro Bonazzola 2014-07-15 06:05:18 UTC
re-targeting to 3.4.3 as per original request.

Comment 4 Sandro Bonazzola 2014-07-18 09:37:30 UTC
This is an automated message

oVirt 3.4.3 has been released:
 * should fix your issue
 * should be available at your local mirror within two days.

If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.