Bug 1103906 - dnf builddep command not working
dnf builddep command not working
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf-plugins-core (Show other bugs)
20
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Ales Kozumplik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2014-06-02 16:35 EDT by Michael Monreal
Modified: 2014-09-30 19:42 EDT (History)
5 users (show)

See Also:
Fixed In Version: dnf-plugins-core-0.1.0-2.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-17 19:26:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Monreal 2014-06-02 16:35:13 EDT
Description of problem:

I am trying to install the builddeps for the "mirall" package (latest official fedora spec). This used to work but right now it does nothing:

sudo dnf builddep -v /home/mimox/rpmbuild/SPECS/mirall.spec
Config time: 0.006
cachedir: /var/cache/dnf/x86_64/20
Failed loading plugin: copr
Loaded plugins: generate_completion_cache, download, builddep, kickstart, noroot, debuginfo-install
initialized BuildDep plugin
initialized Noroot plugin
initialized DebuginfoInstall plugin
dnf version: 0.5.2
hawkey sack setup time: 0.009
Error: no package matched
Cleaning up.


Version-Release number of selected component (if applicable):
dnf-0.5.2-1.fc20.noarch
dnf-plugins-core-0.0.8-2.fc20.noarch

How reproducible: 100%

Steps to Reproduce:
1. rund builddep on some spec file (tested with mirall.spec)

Actual results:
nothing

Expected results:
builddeps would be installed
Comment 1 Parag Nemade 2014-06-03 00:50:56 EDT
Not sure if this issue relates to multilib packages in a same single repo. I just checked this on gnome-shell.spec also and can see the error.

The observation for mirall.spec is that why no failure for qtwebkit-devel and why failure for neon-devel. Then I tried to search those packages

========================= N/S Matched: qtwebkit-devel ==========================
qtwebkit-devel.x86_64 : Development files for qtwebkit
Repo        : @System

qtwebkit-devel.i686 : Development files for qtwebkit
Repo        : updates

=========================== N/S Matched: neon-devel ============================
neon-devel.i686 : Development libraries and C header files for the neon library
Repo        : fedora

neon-devel.x86_64 : Development libraries and C header files for the neon
                  : library
Repo        : fedora


Should builddep plugin needs some fixing?
Comment 2 Ales Kozumplik 2014-06-03 01:57:29 EDT
Thanks for the report, I'll take a look.
Comment 3 Ales Kozumplik 2014-06-03 02:29:03 EDT
Fixed upstream by 6f5e309.
Comment 4 Fedora Update System 2014-06-04 09:19:11 EDT
dnf-plugins-core-0.1.0-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/dnf-plugins-core-0.1.0-1.fc20
Comment 5 Michael Monreal 2014-06-04 13:14:37 EDT
Still no change as far as I can see:

$ rpm -q dnf-plugins-core
dnf-plugins-core-0.1.0-1.fc20.noarch

$ sudo dnf -v builddep rpmbuild/SPECS/mirall.spec 
Config time: 0.006
cachedir: /var/cache/dnf/x86_64/20
Loaded plugins: generate_completion_cache, download, copr, playground, builddep, kickstart, noroot, debuginfo-install
initialized Copr plugin
initialized Playground plugin
initialized BuildDep plugin
initialized Noroot plugin
initialized DebuginfoInstall plugin
dnf version: 0.5.2
hawkey sack setup time: 0.004
Error: no package matched
Cleaning up.
Comment 6 Parag Nemade 2014-06-04 23:30:07 EDT
1) I installed new dnf-plugins-core-0.1.0-1.fc20.noarch 
2) tried to use builddep again on mirall.spec but got the same error message.
3) Found diff for builddep.py from upstream source to tarball packaged source.

Looks like source tarball missed the upstream commit.
Comment 7 Fedora Update System 2014-06-05 00:21:28 EDT
Package dnf-plugins-core-0.1.0-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-plugins-core-0.1.0-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-7072/dnf-plugins-core-0.1.0-1.fc20
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2014-06-05 03:16:46 EDT
dnf-plugins-core-0.1.0-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/dnf-plugins-core-0.1.0-2.fc20
Comment 9 Fedora Update System 2014-06-17 19:26:52 EDT
dnf-plugins-core-0.1.0-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.