Bug 1103967 - Midori is hitting an illegal instruction on AMD MP
Summary: Midori is hitting an illegal instruction on AMD MP
Keywords:
Status: CLOSED DUPLICATE of bug 984689
Alias: None
Product: Fedora
Classification: Fedora
Component: webkitgtk
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-06-03 03:16 UTC by Bruno Wolff III
Modified: 2014-11-19 00:02 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-19 00:02:54 UTC


Attachments (Terms of Use)
gdb output (40.84 KB, text/plain)
2014-06-05 03:46 UTC, Bruno Wolff III
no flags Details
webkit gdb output (39.30 KB, text/plain)
2014-06-13 15:16 UTC, Bruno Wolff III
no flags Details

Description Bruno Wolff III 2014-06-03 03:16:26 UTC
Description of problem:
midori is crashing and repoting an illegal instruction.


Version-Release number of selected component (if applicable):
midori-0.5.8-1.fc21.i686

Steps to Reproduce:
1. Start Midori
2. Browse for a while

Actual results:
bash-4.3$ midori
java version "1.7.0_55"
OpenJDK Runtime Environment (fedora-2.5.0.21.pre04.fc21-i386 u55-b13)
OpenJDK Server VM (build 24.60-b09, mixed mode)
nIllegal instruction

From gdb:
Program received signal SIGILL, Illegal instruction.
0x98e9a4bc in ?? ()

Note that an AMD MP doesn't support SSE2 instructions and this has recently caused some problems for me with ruby libraries (as used by xchat).

Comment 1 Kevin Fenzi 2014-06-04 15:19:07 UTC
If you remove icedtea-web does it start normally?

Nothing else in the backtrace? Can you try a: 

debuginfo-install midori
gdb midori
run
show

and see if it gets us more info?

Comment 2 Bruno Wolff III 2014-06-05 03:46:07 UTC
Created attachment 902380 [details]
gdb output

I got debug output from gdb.
The crashing isn't completely consistent. I sometimes need to do the same thing a few times before midori crashes.

Comment 3 Bruno Wolff III 2014-06-05 03:53:52 UTC
I removed icedtea-web and the behavior was pretty much the same. midori started up and I clicked on a page feature that opened another page a few times until it crashed.

Comment 4 Kevin Fenzi 2014-06-09 02:19:29 UTC
If you do a: 

echo 1 > /proc/sys/kernel/vm/overcommit_memory

does it change anything?

Comment 5 Bruno Wolff III 2014-06-09 02:48:36 UTC
(There was a thinko above, and I used echo 1 > /proc/sys/vm/overcommit_memory .)
I tried switching back and forth between 0 and 1 and in both cases crashes still happened. But it was variable how many times I triggered new tabs before a crash happened.

Comment 6 Kevin Fenzi 2014-06-09 23:43:09 UTC
Does the problem also happen with /usr/libexec/webkitgtk/GtkLauncher ?

Comment 7 Bruno Wolff III 2014-06-10 05:13:53 UTC
/usr/libexec/webkitgtk/GtkLauncher
java version "1.7.0_55"
OpenJDK Runtime Environment (fedora-2.5.0.22.pre04.fc21-i386 u55-b13)
OpenJDK Server VM (build 24.60-b09, mixed mode)
Illegal instruction

A window breifly appears (less than one second) and then it crashes.

Comment 8 Kevin Fenzi 2014-06-10 15:27:10 UTC
ok, then it sounds like this is actually a webkitgtk bug... 

Do you get any better backtrace from the GtkLauncher crash?

Comment 9 Bruno Wolff III 2014-06-10 15:48:13 UTC
I just did a quick test and didn't try to capture another traceback. After my update from the mass rebuild finishes I'll need to reinstall the debug stuff. The update probably won't finish until very late tonight, so it might take me over a day to capture the traceback.

You don't happen to know if epiphany is base on webkit too? I have had epiphany crashes as well, but don't try it as often and haven't filed a bug as yet. But maybe it is the same underlying issue.

Comment 10 Kevin Fenzi 2014-06-10 23:11:43 UTC
No problem. 

Yes, epiphany uses webkitgtk3 (ie, the gtk3 version of webkit). It's the same code, just webkitgtk is gtk2. 

We should probibly move this bug over to webkitgtk and see if anyone there has ideas...

Comment 11 Bruno Wolff III 2014-06-13 15:16:19 UTC
Created attachment 908617 [details]
webkit gdb output

Comment 12 Michael Catanzaro 2014-11-19 00:02:54 UTC

*** This bug has been marked as a duplicate of bug 984689 ***


Note You need to log in before you can comment on or make changes to this bug.