Bug 1104158 - subscription manager version displays "subscription management server:" when the system is not registered to any server
Summary: subscription manager version displays "subscription management server:" when ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager
Version: 6.6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: William Poteat
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks: rhsm-rhel66
TreeView+ depends on / blocked
 
Reported: 2014-06-03 12:09 UTC by Shwetha Kallesh
Modified: 2014-10-14 07:47 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
no documentation required
Clone Of:
Environment:
Last Closed: 2014-10-14 07:47:03 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1384 normal SHIPPED_LIVE subscription-manager bug fix and enhancement update 2014-10-14 01:27:50 UTC

Description Shwetha Kallesh 2014-06-03 12:09:34 UTC
Description of problem:
subscription manager version displays "subscription management server:" when the system is not registered to any server

Version-Release number of selected component (if applicable):
subscription management server: 0.9.15-1
subscription-manager: 1.11.7-1.git.11.ded0e1d.el6
python-rhsm: 1.11.5-1.git.0.9005fac.el6


How reproducible:


Steps to Reproduce:
[root@shwetha-workstation pki]# subscription-manager version
server type: This system is currently not registered.
subscription management server: 0.9.15-1
subscription-manager: 1.11.7-1.git.11.ded0e1d.el6
python-rhsm: 1.11.5-1.git.0.9005fac.el6


Actual results:
subscription management server: 0.9.15-1

Expected results:
subscription management server: Unknown or This system is currently not registered.

Additional info:

Comment 3 William Poteat 2014-06-20 20:27:39 UTC
Better explanation for field. Added rules version to ouput.

commit 62777c44a7a7b9bf4f819cf58b09bc9e19182ff1

Comment 5 Shwetha Kallesh 2014-06-28 16:01:04 UTC
Marking verified!!

server type: This system is currently not registered.
subscription management server: 0.9.20-1
subscription management rules: 5.10
subscription-manager: 1.12.4-1.el6
python-rhsm: 1.12.3-1.git.0.526cd89.el6

Comment 6 errata-xmlrpc 2014-10-14 07:47:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1384.html


Note You need to log in before you can comment on or make changes to this bug.