This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 1104279 - lmiwbem build fails on ppc64(le), s390(x)
lmiwbem build fails on ppc64(le), s390(x)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: lmiwbem (Show other bugs)
20
s390 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Hatina
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ZedoraTracker PPC64LETracker PPCTracker
  Show dependency treegraph
 
Reported: 2014-06-03 13:20 EDT by Jakub Čajka
Modified: 2016-05-31 21:32 EDT (History)
3 users (show)

See Also:
Fixed In Version: lmiwbem-0.2.0-5.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-24 19:22:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch enables build on ppc64(le) and s390(x) (2.65 KB, patch)
2014-06-03 13:20 EDT, Jakub Čajka
no flags Details | Diff
Updated version of patch added ppc(32bit) (2.78 KB, patch)
2014-06-04 05:11 EDT, Jakub Čajka
no flags Details | Diff
Added aarch64 (3.03 KB, patch)
2014-06-04 05:47 EDT, Jakub Čajka
no flags Details | Diff
fix defines for s390(x) (960 bytes, patch)
2014-06-13 06:10 EDT, Dan Horák
no flags Details | Diff

  None (edit)
Description Jakub Čajka 2014-06-03 13:20:08 EDT
Created attachment 901866 [details]
Patch enables build on ppc64(le) and s390(x)

Description of problem:
build fails during configure

Version-Release number of selected component (if applicable):
lmiwbem-0.2.0-4.fc21

How reproducible:
Always

Steps to Reproduce:
1. build packge on secondary arch

Actual results:
build fails

Expected results:
builds successfully

Additional info:
It seems that declaration of secondary archs miss from configure script, in attachment is patch enabling build on secondary arches. But build still fails on s390(x), still looking into it.
Comment 1 Jakub Čajka 2014-06-04 05:11:02 EDT
Created attachment 902080 [details]
Updated version of patch added ppc(32bit)
Comment 2 Jakub Čajka 2014-06-04 05:34:35 EDT
Problems on s390(x) are caused by older version of tog-pegasus in rawhide s390-koji. Package should build, after new version of tog-pegasus is available in rawhide s390-koji.
Comment 3 Jakub Čajka 2014-06-04 05:47:00 EDT
Created attachment 902119 [details]
Added aarch64

At last added aarch64 to configure.
Comment 4 Fedora Update System 2014-06-05 04:40:29 EDT
lmiwbem-0.2.0-4.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/lmiwbem-0.2.0-4.fc20
Comment 5 Fedora Update System 2014-06-09 22:51:17 EDT
Package lmiwbem-0.2.0-4.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing lmiwbem-0.2.0-4.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-7104/lmiwbem-0.2.0-4.fc20
then log in and leave karma (feedback).
Comment 6 Dan Horák 2014-06-13 06:10:38 EDT
Created attachment 908452 [details]
fix defines for s390(x)
Comment 7 Fedora Update System 2014-06-13 08:51:43 EDT
lmiwbem-0.2.0-5.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/lmiwbem-0.2.0-5.fc20
Comment 8 Fedora Update System 2014-06-13 18:49:15 EDT
Package lmiwbem-0.2.0-5.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing lmiwbem-0.2.0-5.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-7361/lmiwbem-0.2.0-5.fc20
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2014-06-24 19:22:11 EDT
lmiwbem-0.2.0-5.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.