Bug 110455 - unable to repair rpm database
unable to repair rpm database
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-19 12:41 EST by Josh
Modified: 2007-04-18 12:59 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-19 12:51:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Josh 2003-11-19 12:41:32 EST
The rpm data base is corrupted and using the standard process that is
listed it will not repair. This is with redhat 9, db3.1  The issue is
listed below:

[root@ieee rpm]# db_verify Packages
db_verify: Old or incorrect DB version; extraneous errors may result
db_verify: DB->verify: Packages: DB_VERIFY_BAD: Database verification
failed
[root@ieee rpm]# mv Packages Packages-ORIG
[root@ieee rpm]# db_dump Packages-ORIG | db_load Packages
db_dump: Packages-ORIG: unsupported hash version: 8
db_dump: open: Packages-ORIG: Invalid argument


Any help at all would be great.
Comment 1 Nalin Dahyabhai 2003-11-19 12:51:38 EST
RPM uses an internalized copy of Berkeley DB, which in this case is
newer than the version of db_recover you have installed.

If you have the rpm-devel package installed, the tools you need for
manipulating the database are in /usr/lib/rpm, and named rpmdb_*
(instead of the default db_*).

If not, use rpm2cpio to extract the contents to a temporary location
and run them from there ("rpm2cpio rpm-devel-4.2.0-0.69.i386.rpm |
cpio -dvi").

Marking as notabug and changing component to 'rpm'.

If the standard process is documented somewhere in RHL documentation,
please let us know so that we can have it changed.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.