Bug 110461 - logwatch does not understand sendmail check_ maillog entries
logwatch does not understand sendmail check_ maillog entries
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: logwatch (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-19 13:43 EST by Larry Fahnoe
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-25 11:34:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Larry Fahnoe 2003-11-19 13:43:35 EST
Description of problem:
When logwatch encounters log entries from check_mail, check_relay and
probably the rest of the check_* routines, it does not parse and
report on them, but rather lists them under **Unmached Entries**.

Logwatch 5.0 fixes this problem.

Version-Release number of selected component (if applicable):
logwatch-4.3.2-2

How reproducible:
Anytime sendmail rejects a message in one of the check_* routines.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Larry Fahnoe 2003-12-17 15:20:17 EST
Elliot,

My statement that logwatch 5.0 fixes this problem is only partially
correct.  5.0 understands some of the check_* routines, but not all of
them.  If you use an RBL list, the messages end up listed as unmatched.

I'd like to have logwatch work as this is included, but maintaining
logwatch is a pain in the neck.  logcheck was originally from Psionic
which is now Cisco, but the project has apparently moved to debian

--Larry
Comment 2 Elliot Lee 2004-08-20 16:28:08 EDT
How are things with this issue in the latest logwatch (5.2.2)?
Comment 3 Larry Fahnoe 2004-08-25 09:38:20 EDT
Elliot,

I just grabbed 5.2.2 from
ftp://ftp.kaybee.org/pub/redhat/RPMS/noarch/logwatch-5.2.2-1.noarch.rpm
and installed it on my RHEL 3 box and it looks like it has much better
support for the various sendmail check_* routines.  Actually, it looks
like there has been a large amount of work done in a lot of places.  

I've only done light testing of the new version but so far it looks
like a thumbs up.  I note that setting Detail in logwatch.conf to Low,
Med, or High does indeed give varrying levels of detail.

--Larry
Comment 4 Elliot Lee 2004-08-25 11:34:47 EDT
Cool... Package will be in rawhide sooner or later.

Note You need to log in before you can comment on or make changes to this bug.