Bug 110473 - NPE in CDT debug hover help "Text Viewer Hover Presenter"
NPE in CDT debug hover help "Text Viewer Hover Presenter"
Status: CLOSED NEXTRELEASE
Product: Red Hat Developer Suite
Classification: Retired
Component: eclipse (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Handcock
eclipse-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-19 15:19 EST by Jeremy Handcock
Modified: 2007-04-18 12:59 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-07 14:48:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeremy Handcock 2003-11-19 15:19:04 EST
Description of problem:
This NPE showed up a few times when testing CDT debug.  This has to do
with the hover help stuff that pops up when you move your mouse over a
variable in the source file while debugging, and it displays the
current value of the variable.

Version-Release number of selected component (if applicable):
snapshot-20031119-eclipse-2.1.1-3


How reproducible: Sometimes


Steps to Reproduce:
1. Debug a program using CDT debug
2. Try using the debug hover help capability
3.
  
Actual results: I get this printed out on the console where I started
eclipse, with nothing in the .log file:

[snip]
Exception in thread "Text Viewer Hover Presenter"
java.lang.NullPointerException
   at
org.eclipse.cdt.debug.internal.ui.editors.DebugTextHover.getHoverInfo(org.eclipse.jface.text.ITextViewer,
org.eclipse.jface.text.IRegion)
(/usr/lib/eclipse/plugins/org.eclipse.cdt.debug.ui_1.2.0/libcdtdebugui.so)
      at
org.eclipse.cdt.internal.ui.editor.CEditorTextHoverDispatcher.getHoverInfo(org.eclipse.jface.text.ITextViewer,
org.eclipse.jface.text.IRegion)
(/usr/lib/eclipse/plugins/org.eclipse.cdt.ui_1.2.0/libcdtui.so)
         at org.eclipse.jface.text.TextViewerHoverManager$2.run()
(/usr/lib/eclipse/plugins/org.eclipse.jface.text_2.1.0/libjfacetext.so)
            at _Jv_ThreadRun(java.lang.Thread) (/lib/ssa/libgcj.so.4.0.0)
               at GC_start_routine (/lib/ssa/libgcj.so.4.0.0)
                  at __clone (/lib/tls/libc-2.3.2.so)
[/snip]

... will investigate further and move the PR upstream.
Comment 1 Tom Tromey 2003-11-21 12:10:29 EST
Jeremy, I'm assigning these to you for triage, since you said
on the list you'd be looking at them.
Comment 2 Jeremy Handcock 2003-12-17 11:41:06 EST
I've been able to reproduce this both when running with libgcj and
with the IBM JVM.  Whenever I fire up a debug session and mouse-over
something I expect a hover-help box from, I am getting this exception.
 I'm looking at it now.
Comment 3 Jeremy Handcock 2004-01-07 14:48:47 EST
I found a fix for this in the upstream 1.2.1 branch (from Mikhail
Khodjaiants at QNX), so I checked in the patch here too.  Closing.
Comment 4 John Healy 2004-03-08 16:21:42 EST
Moving from RHEL/3/Eclipse to Red Hat Developer Suite product.

Note You need to log in before you can comment on or make changes to this bug.