Bug 110477 - fatal IO error 104
fatal IO error 104
Status: CLOSED DUPLICATE of bug 108777
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
1
i686 Linux
high Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-19 16:23 EST by Marco Varanda
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:00:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marco Varanda 2003-11-19 16:23:15 EST
Description of problem:
Running Fedora Core 1 graphic installation generate a "Fatal IO error 
104"

Hardware:
Celeron 1,8 GHz, 256 MB ram, Mother Board ECS P4IBMs
SVGA test 1: Trident 9680 (2mb) (Old)
SVGA test 2: S3 Trio 64 chip 86c764-P (4mb) (old)
SVGA test 3: SiS 305  (32mb)




Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot Fedora Core 1, press Enter, scan cd or skip scan, wait for 
the error.
2.
3.
    
Actual results:
The X server starts, The X mouse cursor appear, the mouse is working, 
but 
immediately exit with those errors/Messages:

Probing for mouse type:   Generic - 2 Button Mouse (serial)
Attempting to start native X server
Waiting for X server to start...log located in /tmp/X.log
1...2...3...4...5.... X server started successfully.
XIO:  fatal IO error 104 (Connection reset by peer) on X server ":1.0"
      after 0 requests (0 known processed) with 0 events remaining.
install exited abnormally
sending termination signals...done
sending kill signals...done
disabling swap...
unmounting filesystems...
        /mnt/runtime done
        disabling /dev/loop0
        /proc/bus/usb done
        /proc done
        /dev/pts done
        /tmp/ramfs done
        /mnt/source done
you may safely reboot your system

Expected results:


Additional info:
Comment 1 Jeremy Katz 2003-11-19 16:45:11 EST
Does booting with 'linux allowcddma' help?
Comment 2 Jean-Denis Langelier 2003-11-21 20:01:32 EST
I am experiencing exactly the same problem.  I have a S3 968 powered
Diamond Stealth  64 with 4Mb of VRAM.  I tried booutting with 'linux
allowcddma', but the problem persists.  The X server seems to come up
but is immediately sht down with the following error message:

Running anaconda, the Fedora Core system installer - please wait...
Probing for video card:   S3 968 (generic)
Probong for monitor type:   Unknown monitor
Probing for mouse type:   Generic - 3 Button Mouse (USB)
Attempting to start native X server
Waiting for X server to start...log located in /tmp/X.log
1...2...3...4...5.... X server started successfully.
XIO:  fatal IO error 104 (Connection reset by peer) on X server ":1.0"
      after 0 requests (0 known processed) with 0 events remaining.
install exited abnormally
sending termination signals...done
sending kill signals...done
disabling swap...
unmounting filesystems...
        /mnt/runtime done
        disabling /dev/loop0
        /proc/bus/usb done
        /proc done
        /dev/pts done
        /tmp/ramfs done
        /mnt/source done
you may safely reboot your system

I also switched the Stealth 64 for a ATI Radeon 64 VIVO (recognised as
a 7200) and everythiong went fine, the graphical install started.  The
issue probably lies with the driver for S3 968 based video cards.

I would really apreciate if someone could tell me how to get around
this problem.

Thanks!

Other hardware:
Asus P5A MotherBoard (ALi M1541 chipset)
AMD K6-2 400MHz
224Mb RAM
AOC A785 CRT
Quantum 8Gb HDD
Acer 6x CD-ROM
3Com 3C905B-TX NIC
Logitech USB mouse
Comment 3 Alexandre Strube 2003-11-26 12:25:00 EST
I'm using a TNT2 video card, same thing.
Comment 4 Alvaro Silva Iribarrem 2004-03-24 14:19:00 EST
I´ve experinced the same difficulty, but a text installation ('linux 
text' in the boot) was enough to solve the problem. Anaconda managed 
to install fedore with no further problem in the text installation.
Comment 5 Jeremy Katz 2004-10-05 11:41:01 EDT

*** This bug has been marked as a duplicate of 108777 ***
Comment 6 Jorge 2005-05-03 11:14:31 EDT
i've the same problem, but i tried with the version 3 and i386 hardware.
Comment 7 Marco Varanda 2005-05-03 23:14:20 EDT
Jeremy Katz - Did you try to change video card ? After you finish install, you
could change to first video card. Sometimes I install with text interface (use
F2 to choose sub-packages). I always install servers without graphical
intercace, but you can choose them in text mode, after install, should works fine.
Once works with "linux lowres" at initial option.
Comment 8 Red Hat Bugzilla 2006-02-21 14:00:04 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.