Bug 1104785 - [RFE] Add settings for password strength and complexity
Summary: [RFE] Add settings for password strength and complexity
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Hosts
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
unspecified
low vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Kedar Bidarkar
URL: http://projects.theforeman.org/issues...
Whiteboard:
: 1256691 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-06-04 16:51 UTC by Dominic Cleal
Modified: 2021-09-01 00:18 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of: 1104665
Environment:
Last Closed: 2017-08-22 14:23:59 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 5663 0 Normal New Configure the default root password policy in 1.5 2021-02-16 07:20:12 UTC
Red Hat Bugzilla 1104665 0 unspecified CLOSED UI inconsistency around root password strength 2021-02-22 00:41:40 UTC
Red Hat Issue Tracker SAT-4828 0 None None None 2021-09-01 00:18:48 UTC
Red Hat Knowledge Base (Solution) 1587263 0 None None None 2021-03-10 14:19:50 UTC

Internal Links: 1104665

Description Dominic Cleal 2014-06-04 16:51:49 UTC
+++ This bug was initially created as a clone of Bug #1104665 +++

1) There is no setting in "Administer" -> "Settings" that allows a user to change the minimum acceptable password length.

2) [RFE] there are no settings for password strength:
length
complexity
characters
etc.

Comment 1 Dominic Cleal 2014-06-04 16:53:39 UTC
Connecting redmine issue http://projects.theforeman.org/issues/5663 from this bug

Comment 3 Bryan Kearney 2015-08-25 17:23:55 UTC
Upstream bug component is Hosts

Comment 4 Bryan Kearney 2016-12-20 18:14:46 UTC
*** Bug 1256691 has been marked as a duplicate of this bug. ***

Comment 5 Tomer Brisker 2017-08-22 14:23:59 UTC
This is currently not planned for an upcoming release. 
Customers requiring complex password policy should use LDAP authentication with IdM/Active Directory integration provided by Satellite, which allow setting custom password policy for users.


Note You need to log in before you can comment on or make changes to this bug.