Bug 1104813 - ant does not properly detect Java version 7
Summary: ant does not properly detect Java version 7
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ant
Version: 6.5
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: 6.8
Assignee: Mikolaj Izdebski
QA Contact: qe-baseos-tools-bugs
URL:
Whiteboard:
Depends On:
Blocks: 1271375 1254457
TreeView+ depends on / blocked
 
Reported: 2014-06-04 18:03 UTC by daryl herzmann
Modified: 2016-05-11 00:14 UTC (History)
7 users (show)

Fixed In Version: ant-1.7.1-14.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-05-11 00:14:11 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0884 0 normal SHIPPED_LIVE ant bug fix update 2016-05-10 22:48:56 UTC

Description daryl herzmann 2014-06-04 18:03:02 UTC
The ant version shipped with RHEL6 can not properly detect Java 7, which means ${ant.java.version} gets set to 1.6 even when 1.7 is installed

For example:

Detected Java version: 1.6 in: /usr/lib/jvm/java-1.7.0-oracle-1.7.0.55.x86_64/jre

It would appear this is hard coded within Ant as this version is too old to support 1.7 ?

http://stackoverflow.com/questions/15418127/ant-1-8-1-showing-incorrect-java-version

Looking at the source of ant, perhaps ant 1.7 does not support java 1.7 :)  Perhaps an RPM requirement should be set on this?  Or can support for this be backported?

Comment 2 Sal Castiglione 2014-09-08 17:52:05 UTC
I'm having this same issue - however, if I install Java 1.6 alongside 1.7, ant seems to function OK (so far)

You can use the 'alternatives' utility to switch between versions of Java:

# /usr/sbin/alternatives --config java

Comment 3 Mikolaj Izdebski 2015-10-19 15:17:11 UTC
Confirmed. Java version detection code in JavaEnvUtils.java needs to be backported from latest upstream Ant.

Comment 6 Mikolaj Izdebski 2015-11-27 15:48:00 UTC
Java 7, 8 and 9 detection was implemented in ant-1.7.1-14.el6

Reproducer:
Run: "ant -diagnostics" with Java 7
Output should contain line: "ant.java.version: 1.7"
When running with Java 8 or 9, the above line should (respectively) state 1.8 or 1.9 instead.

Comment 9 Václav Kadlčík 2016-01-25 07:07:40 UTC
verified in ant-1.7.1-15.el6

Comment 11 errata-xmlrpc 2016-05-11 00:14:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0884.html


Note You need to log in before you can comment on or make changes to this bug.