Bug 1104822 - Users authenticated via external ldap contain no default context/location
Summary: Users authenticated via external ldap contain no default context/location
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Organizations and Locations
Version: 6.0.3
Hardware: x86_64
OS: Linux
high
medium
Target Milestone: Unspecified
Assignee: Daniel Lobato Garcia
QA Contact: Kedar Bidarkar
URL: http://projects.theforeman.org/issues...
Whiteboard:
: 1246670 1280303 1337861 1397185 (view as bug list)
Depends On:
Blocks: 1353215 GSS_Sat6Beta_Tracker, GSS_Sat6_Tracker 1122832 1287901 1394352 1456661
TreeView+ depends on / blocked
 
Reported: 2014-06-04 18:29 UTC by Matthew Davis
Modified: 2021-09-09 11:33 UTC (History)
23 users (show)

Fixed In Version: foreman-1.11.0.58-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1394352 (view as bug list)
Environment:
Last Closed: 2016-12-12 17:09:11 UTC
Target Upstream Version:
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 6372 0 Normal Closed Users authenticated via external ldap contain no default context/location 2020-11-13 17:16:58 UTC
Foreman Issue Tracker 16624 0 Normal Closed Make auth sources taxable 2020-11-13 17:16:58 UTC
Foreman Issue Tracker 16633 0 Normal Closed Auth source controllers uses wrong permissions 2020-11-13 17:16:58 UTC
Red Hat Knowledge Base (Solution) 1460183 0 None None None 2016-08-10 11:20:42 UTC
Red Hat Knowledge Base (Solution) 2332551 0 None None None 2018-02-08 10:23:56 UTC
Red Hat Knowledge Base (Solution) 2775651 0 None None None 2017-07-17 23:03:23 UTC
Red Hat Product Errata RHBA-2016:2940 0 normal SHIPPED_LIVE Satellite 6.2.5 Async Bug Release 2016-12-12 22:08:21 UTC

Description Matthew Davis 2014-06-04 18:29:22 UTC
Upon login using an 'external' user. The user cannot do anything. I've even attempted to specify an external group, but there is no context/location settings in the external group settings.

Comment 1 RHEL Program Management 2014-06-04 18:54:16 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 3 Dominic Cleal 2014-06-25 07:44:21 UTC
Created redmine issue http://projects.theforeman.org/issues/6372 from this bug

Comment 13 Bryan Kearney 2015-02-18 23:02:53 UTC
Upstream bug assigned to tcaspy

Comment 14 Bryan Kearney 2015-08-25 17:23:57 UTC
Upstream bug component is Multi Org

Comment 15 Ohad Levy 2016-02-22 11:05:11 UTC
*** Bug 1246670 has been marked as a duplicate of this bug. ***

Comment 20 Daniel Lobato Garcia 2016-08-10 10:51:54 UTC
*** Bug 1280303 has been marked as a duplicate of this bug. ***

Comment 23 Bryan Kearney 2016-09-21 08:01:38 UTC
Upstream bug assigned to dlobatog

Comment 24 Bryan Kearney 2016-09-21 08:01:47 UTC
Upstream bug assigned to dlobatog

Comment 25 Bryan Kearney 2016-09-27 10:01:42 UTC
Moving this bug to POST for triage into Satellite 6 since the upstream issue http://projects.theforeman.org/issues/6372 has been resolved.

Comment 26 Rob Marti 2016-10-13 02:53:56 UTC
Do we have any ETA for when this will land in Satellite?

Comment 27 Kedar Bidarkar 2016-12-08 19:53:58 UTC
This bug is verified with Sat6.2.5 satellite-6.2.5-1.0.el7sat.noarch

Now upon trying to create a LDAP auth source, for the ldap auth source we need to specify the taxonomies ( i.e, ORG and LOC ).

After, configuring external user-groups and upon the user trying to login to sat6, the user was able to inherit the ORG and LOC from the set values of LDAP auth source.

----

Some detailed explanation from the commit which fixes this issue,

In an installation that uses taxonomies, when an user logs in for
the first time and gets its account created via LDAP, it has no
taxonomies.

This is a problem, as even if the user has all the roles it needs from
external user groups, an admin needs to manually set the taxonomies for
every new user.

This commit fixes that by assigning the taxonomies from the LDAP auth
source to the user when it logs in for the first time. It does not
update them on every login, as after the user has logged in, user
taxonomies are left to the Foreman administrator to manage.

----

Comment 29 errata-xmlrpc 2016-12-12 17:09:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:2940

Comment 30 Marek Hulan 2017-05-09 06:58:13 UTC
*** Bug 1397185 has been marked as a duplicate of this bug. ***

Comment 31 Tomer Brisker 2018-02-08 10:23:56 UTC
*** Bug 1337861 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.