This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 110486 - History file causes mozilla to segv.
History file causes mozilla to segv.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: mozilla (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-19 19:49 EST by Sam Varshavchik
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-25 07:59:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Last few pages of the strace. (17.35 KB, text/plain)
2003-11-19 19:49 EST, Sam Varshavchik
no flags Details
history.dat (116.20 KB, application/octet-stream)
2003-11-19 19:50 EST, Sam Varshavchik
no flags Details
history.mab (13.26 KB, application/octet-stream)
2003-11-19 19:51 EST, Sam Varshavchik
no flags Details

  None (edit)
Description Sam Varshavchik 2003-11-19 19:49:08 EST
Description of problem:

Today, Mozilla decided that it is going to SEGV on me every time I
click on the URL field, and press 'w'.  Only 'w', and only in the
beginning of the URL field.

An investigation showed the somehow the history file got corrupted. 
Removing history.dat and history.mab fixes the bug.  It looks like the
corrupted history file causes Mozilla to segv when it tries to show
the URL field's dropdown box.  I can briefly see a lowercase 'w'
appearing in the URL field, before Mozilla segv's.

I'm attaching the last few pages of strace, and the GZIPped
history.dat and history.mab files which demonstrate the bug.

Version-Release number of selected component (if applicable):

1.4.1-17

How reproducible:

Always

Steps to Reproduce:
1. Ungzip the following history.mab and history.dat files from this
bug, and move them to your ~/.mozilla/default directory.
2. Start mozilla
3. Click on the URL field, which auto-selects its existing contents.
4. Press 'w'.
  
Additional info:

I haven't messed around with .mozilla in ages.  There were no recent
crashes that might've corrupted the history file independently of Mozilla.
Comment 1 Sam Varshavchik 2003-11-19 19:49:57 EST
Created attachment 96075 [details]
Last few pages of the strace.
Comment 2 Sam Varshavchik 2003-11-19 19:50:52 EST
Created attachment 96076 [details]
history.dat

Must un-gzip this file before installing it.
Comment 3 Sam Varshavchik 2003-11-19 19:51:52 EST
Created attachment 96077 [details]
history.mab

Must un-gzip this attachment before installing it.
Comment 4 Warren Togami 2005-04-25 04:00:31 EDT
Is this still an issue?
Comment 5 Sam Varshavchik 2005-04-25 07:59:16 EDT
No.

Note You need to log in before you can comment on or make changes to this bug.