Bug 110488 - importing new printer is very slow
importing new printer is very slow
Status: CLOSED DEFERRED
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: redhat-config-printer (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-19 21:26 EST by Jeff Bastian
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-20 05:18:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Bastian 2003-11-19 21:26:53 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20031022

Description of problem:
Our environment has over 500 networked (LPD) printers.  There does not
seem to be a way to add a new LPD printer at the command line, so I've
written a Perl script to spit out a settings.xml file with entries for
each of the printers, then I import that file:
   printconf-tui --Ximport settings.xml

This works fine, but when I restart the cups daemon, it takes well
over 5 minutes (on a 2.0GHz P4!) to start as it has to generate over
500 ppd files in /etc/cups/ppd/*.ppd

This, too, would be fine if it only happened once, however, if I add
one printer, regenerate and import settings.xml, and restart cups, it
regenerates _all_ the *.ppd files.  It regenerates all files
regardless if I use --merge or --force with printconf-tui.

I've tried adding a printer with --merge and only one printer in the
settings.xml file, and I've tried with all 500+ printers in
settings.xml and that doesn't affect it either.  As long as an import
was done, all *.ppd files are rebuilt.

Is there a way to only generate *.ppd files for new printers, or
better yet, a way to add LPD printers without having to go through
import/export of the xml file?


Version-Release number of selected component (if applicable):
cups-1.1.17-13.3.6

How reproducible:
Always

Steps to Reproduce:
1. Generate a settings.xml file for new printer
2. Import it with printconf-tui
3. Restart cups and don't hold your breath
    

Actual Results:  Hurry up and wait.

Expected Results:  A delay of a few seconds or less.
Comment 1 Tim Waugh 2003-11-20 05:18:14 EST
This is a shortcoming of the design of the redhat-config-printer tool,
and is something that only a re-write can fix. :-((

You *could* add LPD printers via the CUPS web interface,
http://localhost:631/ -- but those printers won't be editable in the
redhat-config-printer tool then.

Closing this as DEFERRED, since it's not really something that an RHBA
or anything can really address -- but it's an issue which a future
release hopefully *will* address.

Note You need to log in before you can comment on or make changes to this bug.