Bug 110494 - [PATCH] HIG-ify r-c-h dialogs
Summary: [PATCH] HIG-ify r-c-h dialogs
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: redhat-config-httpd   
(Show other bugs)
Version: 1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-11-20 07:26 UTC by Jens Knutson
Modified: 2015-03-05 01:13 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-03 16:19:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
HIG-ification patch (599.67 KB, patch)
2003-11-20 07:34 UTC, Jens Knutson
no flags Details | Diff

Description Jens Knutson 2003-11-20 07:26:29 UTC
Changes to all dialogs:
==========

* I only touched the small dialogs for now - the main and vhost pages
have stayed untouched

* All separators between the contents of a window and the button boxes
have been removed, per the HIG

* All spacings and borders have been corrected for HIG compliance

* Button orderings have also all been corrected per the HIG

* when fixing their order, I also gave OK and Cancel buttons proper
names (ie: "button28" became "error_document_dialog_ok_button")

* changed all instances of icky old question mark icon, like in the
vhost_alias_dialog, to use the stock gnome question icon 


error_document_dialog:
=======================

* fixed "Location" label by adding colon, to read "Location:"

Comment 1 Jens Knutson 2003-11-20 07:34:26 UTC
Created attachment 96079 [details]
HIG-ification patch

Warning: this is huge, for some reason.  I only changed a few things, but the
diff is 600K!  I'm no diff expert, so I'm not sure if this is significant or
not...

Comment 2 Phil Knirsch 2003-11-27 08:50:10 UTC
Thanks for the patch, Jens, will look into it today.

Sorry again that it took so long until i got a chance to review it.
Will post my results here and what i did with the patch. ;-)

Read ya, Phil

Comment 3 Phil Knirsch 2003-11-28 11:06:39 UTC
OK, patch applied, but i now get some bugs and problems with some
buttons etc.

Will fix today.

Read ya, Phil

Comment 4 Jens Knutson 2003-11-28 19:20:34 UTC
Well, glad to hear it *mostly* worked. ;)

When you solve the problems with the buttons, let me know what's up,
and if there's something I should be doing differently.  Also, any
idea about the bizzare size of the patch?

Thanks for taking a look at this, Phil!

Comment 5 Phil Knirsch 2003-12-03 16:19:15 UTC
Well, the size change might have come from the fact that, although
r-c-h worked with gtk2 it was still a glade1 based app and most if not
all gtk2 changes and fixes had been done using glade1 or vi. ;-)

The latest glade2 seems to handle old glade1 files a lot better, so
everything still seems to be preserved.

I ended up only having to do small changes to the glade file after i
patched it, so looks good.

The buttons problem seems to be a libglade problem. I get loads of
warnings about adding a GtkLable to a GtkButton, will file a bz today
or tomorrow.

I'll be doing some more fixes to the package and rename it to
system-config-httpd before i make the next final package for fc2.

Should still make it by the end of this week. ;-)

Read ya, Phil


Note You need to log in before you can comment on or make changes to this bug.