Bug 1104951 - spamming /run/user/$UID/pulse Permission denied messages
spamming /run/user/$UID/pulse Permission denied messages
Status: CLOSED DUPLICATE of bug 753882
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
20
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2014-06-05 01:21 EDT by Raphael Groner
Modified: 2014-11-16 08:14 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-11-16 08:14:33 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
journalctl -ax |egrep -i "snd|pulse|audio|alsa" (56.00 KB, text/x-log)
2014-06-05 01:21 EDT, Raphael Groner
no flags Details
dmesg |egrep -i "snd|pulse|audio|alsa" (1.57 KB, text/x-log)
2014-06-05 01:24 EDT, Raphael Groner
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 42804 None None None Never

  None (edit)
Description Raphael Groner 2014-06-05 01:21:24 EDT
Created attachment 902404 [details]
journalctl -ax |egrep -i "snd|pulse|audio|alsa"

Description of problem:
PUlseAudio seems to crash always. There's no sound at all.

$ LC_ALL=C alsamixer 
Failed to create secure directory (/run/user/1000/pulse): Permission denied
ALSA lib pulse.c:243:(pulse_connect) PulseAudio: Unable to connect: Connection refused

cannot open mixer: Connection refused


Version-Release number of selected component (if applicable):
pulseaudio-4.0-13.gitf81e3.fc20.x86_64
alsa-utils-1.0.27.2-4.fc20.x86_64
kernel-3.14.3-200.fc20.x86_64

How reproducible:
yes

Steps to Reproduce:
1.
2.
3.

Actual results:
see logs

Expected results:
sound

Additional info:
Upstream seems to be aware: https://bugs.freedesktop.org/show_bug.cgi?id=42804
Comment 1 Raphael Groner 2014-06-05 01:24:02 EDT
Created attachment 902405 [details]
dmesg |egrep -i "snd|pulse|audio|alsa"
Comment 2 Raphael Groner 2014-06-05 01:57:06 EDT
I have reinstalled alsa-plugins-pulseaudio, restarted, sound works again.

$ su -c 'yum remove -y alsa-plugins-pulseaudio && yum install -y alsa-plugins-pulseaudio'
reboot
Comment 3 Raphael Groner 2014-10-30 10:17:12 EDT
Well, that could be a workaround / temporary fix:

# chgrp -R pulse /run/user/*/pulse
# usermod -a -G pulse $USER
Comment 4 Rex Dieter 2014-10-30 10:25:27 EDT
https://bugs.freedesktop.org/show_bug.cgi?id=42804
seems to be an incorrect reference, it talks about 
"raop module does not work with shairport"
which doesnt seem relevant here.

before the workaround in comment #3, what was the ownership/permissions of /run/user/1000/pulse 
?
Comment 5 Rex Dieter 2014-10-30 10:26:35 EDT
and does 'loginctl' list your session (and as active)?
Comment 6 Rex Dieter 2014-10-30 10:31:00 EDT
If its owned by root, I suspect bug #753882 is relevant
Comment 7 Raphael Groner 2014-10-30 11:07:34 EDT
(In reply to Rex Dieter from comment #4)

> before the workaround in comment #3, what was the ownership/permissions of
> /run/user/1000/pulse 
> ?
# ls -ld /run/user/1000/pulse/
drwx------. 2 raphael raphael 80 30. Okt 10:49 /run/user/1000/pulse/
# id raphael
uid=1000(raphael) gid=1000(raphael) Gruppen=1000(raphael),991(pulse),1001(build),980(yumex)

I guess additionally to comment #3 the following will be needed:
# chmod g+rx /run/user/*/pulse


(In reply to Rex Dieter from comment #5)
> and does 'loginctl' list your session (and as active)?
# loginctl
   SESSION        UID USER             SEAT            
         1       1000 raphael          seat0           

1 sessions listed.


(In reply to Rex Dieter from comment #6)
> If its owned by root, I suspect bug #753882 is relevant
What should be owned by root? I guess it's fatal in general to let root own something under /home … So not sure if bug #753883 is connected anyhow.
# ls -l /run/user
insgesamt 0
drwx------.  3 root    root     60 30. Okt 11:01 0
drwx------. 14 raphael raphael 300 30. Okt 14:25 1000


Summary: I would prefer the solution with setting correct group access.
Comment 8 Rex Dieter 2014-10-30 12:01:55 EDT
group access shouldn't be required, why do you think you need it?
Comment 9 Raphael Groner 2014-11-16 08:14:33 EST

*** This bug has been marked as a duplicate of bug 753882 ***

Note You need to log in before you can comment on or make changes to this bug.