Bug 1104968 - prebuilt binary without build-id gets installed
prebuilt binary without build-id gets installed
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
rawhide
s390x Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mat Booth
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ZedoraTracker
  Show dependency treegraph
 
Reported: 2014-06-05 02:53 EDT by Dan Horák
Modified: 2014-10-07 10:16 EDT (History)
10 users (show)

See Also:
Fixed In Version: eclipse-4.4.1-2.fc21
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-07 10:16:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Horák 2014-06-05 02:53:56 EDT
This is rather a reminder of what I have found, no need to react now as s390 is still catching primary koji. The pre-built eclipse binary (.../contributed/gtk/linux/s390x/eclipse) gets installed, not the built one, and the build then fails with

...
~/build/BUILD/R4_platform-aggregator-I20140506-2000
+ find /builddir/build/BUILDROOT/eclipse-4.4.0-0.17.git201405062000.fc21.s390x//usr/lib64/eclipse -name '*.so' -exec chmod a+x '{}' ';'
+ /usr/lib/rpm/find-debuginfo.sh --strict-build-id -m --run-dwz --dwz-low-mem-die-limit 10000000 --dwz-max-die-limit 50000000 /builddir/build/BUILD/R4_platform-aggregator-I20140506-2000
extracting debug info from /builddir/build/BUILDROOT/eclipse-4.4.0-0.17.git201405062000.fc21.s390x/usr/lib64/eclipse/eclipse
*** ERROR: No build ID note found in /builddir/build/BUILDROOT/eclipse-4.4.0-0.17.git201405062000.fc21.s390x/usr/lib64/eclipse/eclipse
error: Bad exit status from /var/tmp/rpm-tmp.4o9roZ (%install)
RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.4o9roZ (%install)
Child return code was: 1


full logs are http://s390.koji.fedoraproject.org/koji/taskinfo?taskID=1424326

Version-Release number of selected component (if applicable):
>= eclipse-4.4.0-0.15.git201404280800.fc21 (now at 0.17)
Comment 1 Alexander Kurtakov 2014-06-05 03:05:39 EDT
Mat, please make sure that we remove these when creating the source tarball.
Comment 2 Mat Booth 2014-06-06 10:41:40 EDT
The pre-built binaries are now deleted when the source tarball is created so they definitely won't be installed instead of built one. I have not yet tried building eclipse-4.4.0-0.27.git201406042000.fc21 for s390 because the xmvn is not new enough on that platform.

I will not close this bug until I can verify it's definitely fixed on s390.
Comment 3 Dan Horák 2014-06-06 11:19:32 EDT
(In reply to Mat Booth from comment #2)
> The pre-built binaries are now deleted when the source tarball is created so
> they definitely won't be installed instead of built one. I have not yet
> tried building eclipse-4.4.0-0.27.git201406042000.fc21 for s390 because the
> xmvn is not new enough on that platform.
> 
> I will not close this bug until I can verify it's definitely fixed on s390.

There is currently xmvn-2.0.0-6.fc21 (1 day old today) in s390, but rather I think the eclipse-4.4.0-0.12.git201404220800.fc21 in the buildroot might be too old. I'll come back to you when I have fully up-to-date repos on s390.

Note You need to log in before you can comment on or make changes to this bug.