Bug 110497 - Latest XFree86 Upgrade to RH.9 Breaks KDE Anti-aliased fonts
Latest XFree86 Upgrade to RH.9 Breaks KDE Anti-aliased fonts
Status: CLOSED DUPLICATE of bug 109351
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-20 04:38 EST by Mark Vevers
Modified: 2007-04-18 12:59 EDT (History)
0 users

See Also:
Fixed In Version: 109351
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:00:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Snapshot of OpenOffice font selector showing corrupted font list (2.63 KB, image/png)
2003-11-20 06:14 EST, Mark Vevers
no flags Details

  None (edit)
Description Mark Vevers 2003-11-20 04:38:04 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1)
Gecko/20030225

Description of problem:
After upgrading to latest version of Xfs and XFREE-86 (4.3.0-2.90.43)
All KDE applications no longer render antialised fonts.
Mozilla and all Gnome Apps are OK.

No antialised fonts appear in KDE font selector and the font 'Sans 10'
which is the default font for KDE in RH9 is not even listed.

XFS reports no errors on start up.
No other font errors in X startup log.

Version-Release number of selected component (if applicable):
XFree86-xfs-4.3.0-2.90.43

How reproducible:
Always

Steps to Reproduce:
1.Upgrade RH.9 with latest X
2.Log in to KDE desktop
3.Open any KDE application.  - almost unreadable at 1152x864
4.Open gnome application. - fonts look fine.

Actual Results:  All KDE fonts are extremely small unreadable and not
antialiased.
Readability is SEVERLY compromised.

Workaround - use large horrible unantialised fonts.

Expected Results:  The base font should appear the same whether
running KDE or GNOME.
Comment 1 Mark Vevers 2003-11-20 06:08:23 EST
All icons in on KDE kicker no longer smoth edged - i.e. openoffice
icons now jagged round the edges.

Open office locks up X completely when displaying all fonts in font
picker.  Killing openoffice from terminal sessions restores X

Tried creating new user and logging in as them.  Doesn't fix problem - 
=> not local user settings.

(BTW I rebooted before filing inital report just to check).

chkfontpath reports:
$ chkfontpath
Current directories in font path:
1: /usr/X11R6/lib/X11/fonts/misc:unscaled
2: /usr/X11R6/lib/X11/fonts/75dpi:unscaled
3: /usr/X11R6/lib/X11/fonts/100dpi:unscaled
4: /usr/X11R6/lib/X11/fonts/misc
5: /usr/X11R6/lib/X11/fonts/Type1
6: /usr/X11R6/lib/X11/fonts/Speedo
7: /usr/X11R6/lib/X11/fonts/cyrillic
8: /usr/X11R6/lib/X11/fonts/TTF
9: /usr/share/fonts/default/Type1
10: /usr/lib/openoffice/share/fonts/truetype
Comment 2 Mark Vevers 2003-11-20 06:14:30 EST
Created attachment 96086 [details]
Snapshot of OpenOffice font selector showing corrupted font list

Open office Font selector is corrupted.
If I scroll further down OpenOffice locks X completely until I kill openoffice
from a console

Note - these fonts do not appear in KDE font selector at all - in fact non of
the AA fonts appear
Comment 3 Mark Vevers 2003-11-20 06:37:41 EST
Ok - found bug 109351 which is against Fedora Core 1
I also use a 'xinerama' setup but with twi graphics cards.

Downgrading to XFree86-libs-4.3.0-2 (i.e. RH9 original) appears to
fix the problem, although OpenOffice is still unstable W.r.t. to fonts
when browsing the help and opening certain MSFT.doc documents - lockup
is the same as when just display the fonts caused the problem - I
suspect the still a fault - but I can't track it down.

There is definitely a problem with XFree86-libs-4.3.0-2.90.43.i386.rpm
as it breaks all qt edge smoothing (such as icons on kicker) and
anti-aliasing.
Comment 4 Mark Vevers 2003-11-20 06:46:23 EST
I am using the nvidia drivers on this machines so I can get xinerama
support however I don't think that is the problem see bug 109351
comment #8 From Scott Phipps - it happens on the ATI radeon 7500's
with xinerama enabled as well so it looks more like an
X-Libs/xinerama/qt related bug.

Just tested on my old desktop with RH9 and stock ATI drivers and new
X + xinerama.  Anti-aliased fonts break.
Comment 5 Owen Taylor 2003-11-20 10:26:00 EST
Don't think this is Xft related (and Xft is part of the
XFree86 packages currently anyways.)
Comment 6 Owen Taylor 2003-11-20 10:26:30 EST

*** This bug has been marked as a duplicate of 109351 ***
Comment 7 Red Hat Bugzilla 2006-02-21 14:00:04 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.