Bug 1105078 - [GSS](6.3.0)HHH-9062 Envers validity audit strategy: end revision timestamp is not stored in tables for joined subclasses
Summary: [GSS](6.3.0)HHH-9062 Envers validity audit strategy: end revision timestamp i...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Hibernate
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: EAP 6.3.0
Assignee: Gail Badner
QA Contact: Martin Simka
Russell Dickenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-06-05 10:42 UTC by Fedor Gavrilov
Modified: 2019-09-12 07:54 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Known Issue
Doc Text:
In this release of JBoss EAP 6, when Envers is used with a validity audit strategy to audit an entity hierarchy using JOINED inheritance, the resulting audit tables created for the joined subclasses do not contain the end revision column. This can complicate partitioning the audit tables for joined subclasses. This issue is under investigation.
Clone Of:
Environment:
Last Closed: 2014-08-15 18:43:55 UTC
Type: Bug


Attachments (Terms of Use)

Description Fedor Gavrilov 2014-06-05 10:42:17 UTC
Description of problem:
https://hibernate.atlassian.net/browse/HHH-9062

Comment 1 Gail Badner 2014-06-05 18:35:03 UTC
Fedor Gavrilov, this issue shows version 6.2.4. Is that correct?

Comment 2 Fedor Gavrilov 2014-06-10 09:57:07 UTC
Gail, I've set version to the latest because it seems that nobody tried to fix that yet, so it should be present in teh latest version of EAP. My wrong, probably. 
I am pretty sure that customer uses 6.2.0. I explicitly asked him to verify the version.
Is this fine for you to proceed or should we wait for the customer's reply?

Comment 3 Fedor Gavrilov 2014-06-10 12:10:02 UTC
Customer confirmed - version is 6.2.0

Comment 4 Fedor Gavrilov 2014-06-16 07:41:53 UTC
Are there any estimates for this bug?

Comment 6 Gail Badner 2014-07-09 03:13:04 UTC
I'm not sure if this is really a bug. I need to discuss with someone knowledgeable about partitioning database tables. I'm not sure I'll have an answer immediately. 

It might be better to say that this is in the process of being researched.

Comment 7 Fedor Gavrilov 2014-08-15 10:26:50 UTC
Hello,

Are there any news regarding this bug/not a bug?

Comment 8 Gail Badner 2014-08-15 18:43:55 UTC
This would be a new feature. I'm closing as NOTABUG.


Note You need to log in before you can comment on or make changes to this bug.