Bug 110516 - TB GUI_functions.py:524:gui_run_dialog:OSError: [Errno 1] Operasjonen er ikke tillatt
TB GUI_functions.py:524:gui_run_dialog:OSError: [Errno 1] Operasjonen er ikke...
Status: CLOSED DUPLICATE of bug 109604
Product: Fedora
Classification: Fedora
Component: redhat-config-network (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-20 12:33 EST by Kyrre Ness Sjøbæk
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:00:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
"Network Device Control" crash dump after pressing the cancel button (2.15 KB, text/plain)
2003-11-20 13:01 EST, petrosyan
no flags Details

  None (edit)
Description Kyrre Ness Sjøbæk 2003-11-20 12:33:37 EST
Description of problem:
I have given ordinary users the rigth to activate eth0 (in neat), but 
when I try to do so (in redhat-config-network, applications -> system 
tools -> network device control or something like that), pushing 
activate works fine. But if I push cancel, the app crashes

Reasons to push cancel:
- My smootwall (dhcp) box is off, don't care to wait
- Network jack not plugged in
- etc

Version-Release number of selected component (if applicable):
1.3.10

How reproducible:
every time i tried, it crashed

Steps to Reproduce:
1. Open redhat-config-network
2. Push "activate"
3. Push cancel, dont wait for it to finish getting the IP info
  
Actual results:
Component: redhat-config-network
Version: 1.3.10
Summary: TB3fbf821d GUI_functions.py:524:gui_run_dialog:OSError: 
[Errno 1] Operasjonen er ikke tillatt
Traceback (most recent call last):
  File "/usr/bin/redhat-control-network", line 184, in 
on_activateButton_clicked
    (ret, msg) = dev.activate()
  File 
"/usr/src/build/320592-noarch/install/usr/share/redhat-config-network
/netconfpkg/NCDevice.py", line 385, in activate
    dialog = dialog)
  File 
"/usr/src/build/320592-noarch/install/usr/share/redhat-config-network
/netconfpkg/NC_functions.py", line 512, in generic_run_dialog
    dialog = dialog)
  File 
"/usr/src/build/320592-noarch/install/usr/share/redhat-config-network
/netconfpkg/gui/GUI_functions.py", line 524, in gui_run_dialog
OSError: [Errno 1] Operasjonen er ikke tillatt

Local variables in innermost frame:
fdin: []
swindow: <gtk.ScrolledWindow object (GtkScrolledWindow) at 0x9139dec>
string: <module 'string' from '/usr/lib/python2.2/string.pyc'>
okbutton: <gtk.Button object (GtkButton) at 0x9139e74>
buffer: <gtk.TextBuffer object (GtkTextBuffer) at 0x9147acc>
cancelbutton: <gtk.Button object (GtkButton) at 0x913a44c>
command: /sbin/ifup
argv: ['/sbin/ifup', 'eth0', 'up']
searchPath: 0
CancelException: netconfpkg.gui.GUI_functions.CancelException
root: /
label: Aktiverer nettverksenhet eth0, vennlist vent...
lbl: <gtk.Label object (GtkLabel) at 0x9139dc4>
select: <module 'select' from '/usr/lib/python2.
2/lib-dynload/selectmodule.so'>
stdin: 0
xml: <gtk.glade.XML object (GladeXML) at 0x8c79bdc>
catchfd: (1, 2)
fderr: []
dlg: <gtk.Dialog object (GtkDialog) at 0x909551c>
errlabel: Kan ikke aktivere nettverksenhet eth0!

fdout: []
vadj: <gtk.Adjustment object (GtkAdjustment) at 0x90a422c>
gtk: <module 'gtk' from '/usr/lib/python2.2/site-packages/gtk-2.
0/gtk/__init__.pyc'>
iter: <GtkTextIter at 0x91479e8>
mark: <gtk.TextMark object (GtkTextMark) at 0x9147c8c>
write: 4
read: 3
s: Determining IP information for eth0...
childpid: 7079
closefd: -1
dialog: None
rc: 
Determining IP information for eth0...
title: redhat-config-network:

Nettverksenheten aktiveres...
os: <module 'os' from '/usr/lib/python2.2/os.pyc'>
textview: <gtk.TextView object (GtkTextView) at 0x91402d4>


Expected results:
it should be canceled!

Additional info:

Language: Norwegian
Using DHCP
Usually the dhcp server sets the hostname (if booted with network 
connected (laptop))
Comment 1 Kyrre Ness Sjøbæk 2003-11-20 12:35:35 EST
As i see you are norwegian, (or guess by your name at least) here are 
the norwegian instructions for opening the app (through a NOR menu):

Applikasjoner (gnome) -> systemverktøy -> kontroll av nettverksenhet
Comment 2 petrosyan 2003-11-20 13:00:08 EST
I get the same behaviour on a US English system.
I am also attaching the crash dump.
Comment 3 petrosyan 2003-11-20 13:01:09 EST
Created attachment 96091 [details]
"Network Device Control" crash dump after pressing the cancel button
Comment 4 Harald Hoyer 2003-11-25 10:50:32 EST

*** This bug has been marked as a duplicate of 109604 ***
Comment 5 Red Hat Bugzilla 2006-02-21 14:00:04 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.