Bug 1105230 - FTFBS: mongodb24 BuildRequires: %{?scl_prefix}scons
Summary: FTFBS: mongodb24 BuildRequires: %{?scl_prefix}scons
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Software Collections
Classification: Red Hat
Component: mongodb24
Version: mongodb24
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: rc
: 2.0
Assignee: jpacner
QA Contact: BaseOS QE - Apps
URL:
Whiteboard:
: 1108815 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-06-05 16:07 UTC by Pat Riehecky
Modified: 2014-08-31 23:17 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-30 14:02:58 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Pat Riehecky 2014-06-05 16:07:52 UTC
Description of problem: mongodb24-mongodb-2.4.9-8.el6.src.rpm has a build requires of 

BuildRequires:  %{?scl_prefix}scons

However, no such package is provided by the release.


Version-Release number of selected component (if applicable):mongodb24-mongodb-2.4.9-8.el6.src.rpm


How reproducible:100%


Steps to Reproduce:
1.rpmbuild --rebuild mongodb24-mongodb-2.4.9-8.el6.src.rpm
2.
3.

Actual results:
Error: No Package found for mongodb24-scons

Expected results:
ability to rebuild from source

Additional info:

Comment 2 Johnny Hughes 2014-07-08 20:55:10 UTC
I also see this same issue, I found this version:

http://copr-be.cloud.fedoraproject.org/results/rhscl/mongodb24/epel-6-x86_64/mongodb24-scons-2.3.0-2.el6/mongodb24-scons-2.3.0-2.el6.src.rpm

That is the same changelog as the one here:
https://www.softwarecollections.org/repos/rhscl/mongodb24/epel-6-x86_64/

So, that seeem to be the version whose SRPM is missing from ftp.redhat.com

Comment 3 Lubos Kocman 2014-07-09 14:37:14 UTC
Hello,

as far as I'm aware we don't guarantee rebuilds (no self-hosting support). Not all build dependencies are part of the product.

Suggesting to close as a NOTABUG.

Lubos
rel-eng

Comment 4 Lubos Kocman 2014-07-09 14:38:01 UTC
*** Bug 1108815 has been marked as a duplicate of this bug. ***

Comment 5 Brian Gollaher 2014-07-30 14:02:58 UTC
Comment 3 is correct.  We don't guarantee self hosting in RHEL.  Suggest addressing this through softwarecollections.org.


Note You need to log in before you can comment on or make changes to this bug.