Bug 1105269 - Removed resources are not auto-uninventoried from EAP6.0.0
Summary: Removed resources are not auto-uninventoried from EAP6.0.0
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: Inventory, UI
Version: JON 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: DR01
: JON 3.3.0
Assignee: Stefan Negrea
QA Contact: Mike Foley
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-06-05 18:01 UTC by Armine Hovsepyan
Modified: 2015-09-03 00:02 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-12-11 14:01:43 UTC
Type: Bug


Attachments (Terms of Use)
eap600_removed_app_not-autouninventoried (302.17 KB, image/png)
2014-06-05 18:01 UTC, Armine Hovsepyan
no flags Details
auto_uninventoried (88.15 KB, image/png)
2014-08-01 13:35 UTC, Armine Hovsepyan
no flags Details

Description Armine Hovsepyan 2014-06-05 18:01:41 UTC
Created attachment 902619 [details]
eap600_removed_app_not-autouninventoried

Description of problem:
Removed resources are not auto-uninventoried from EAP6.0.0

Version-Release number of selected component (if applicable):
RHQ Masteer

How reproducible:
always

Steps to Reproduce:
1. install EAP 6.0.0 and connect to running RHQ/JON
2. deploy   web application (see in deployment)
3. mark Uninventiry missing resource policy or AS7 -> deployments (from serveri gui Administration)
4. undeploy application from management console or jboss-cli

Actual results:
removed/ndeployed application visible in inventory list (server gui)


Expected results:
removed application is auto-uninventoried from linventory list

Additional info:
screenshot attached

marking bz urgent since it blocks jon3-42 qualification (for eap 6.0.0) & fix will require regression testing for jon3-42

Comment 1 Armine Hovsepyan 2014-06-13 12:58:22 UTC
the bug is visible for EAP6.2 as well

Comment 2 Jay Shaughnessy 2014-06-13 14:59:36 UTC
This is due to differences in returned responses when we make the ReadAttribute call to see if the resource exists/isEnabled.  Looking at how to make this more consistent.  I think we need to use ReadResource instead...

Comment 3 Stefan Negrea 2014-06-20 21:59:08 UTC
Switched the availability implementation to use ReadResource and then extract the enabled attribute. This DMR call is more reliable in detecting missing resources. The new code will correctly report a resource as missing.


master branch commit:

https://github.com/rhq-project/rhq/commit/a87bc93b3f46d43058258439b2e2dc43a3a48ebe

Comment 4 Armine Hovsepyan 2014-06-24 13:06:57 UTC
verified in eap-6.2.0

Comment 5 Heiko W. Rupp 2014-06-30 09:54:37 UTC
Re-setting back to MODIFIED as there is no Brew build for testing available yet.

Comment 6 Simeon Pinder 2014-07-31 15:52:27 UTC
Moving to ON_QA as available to test with brew build of DR01: https://brewweb.devel.redhat.com//buildinfo?buildID=373993

Comment 7 Armine Hovsepyan 2014-08-01 13:35:48 UTC
Created attachment 923323 [details]
auto_uninventoried

Comment 8 Armine Hovsepyan 2014-08-01 13:36:14 UTC
verified in jon 3.3 dr1 -- screen-shot attached


Note You need to log in before you can comment on or make changes to this bug.