Bug 110553 - nautilus crashes when browsing non-local shares
nautilus crashes when browsing non-local shares
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Alexander Larsson
Depends On:
  Show dependency treegraph
Reported: 2003-11-20 22:31 EST by Justin Georgeson
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-02-09 04:27:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Justin Georgeson 2003-11-20 22:31:06 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5)
Gecko/20031110 Firebird/0.7

Description of problem:
I have two machines on my LAN, a laptop and a desktop. Both are
running Fedora Core 1, and appear to be fully patched with released
updates. I have the desktop set with OS level 33 and prefered/local
master set enabled. The laptop has the default OS level of 20 and
prefered/local master disabled. Both have security set to user. When I
browse the SMB LAN with the desktop, I am able to browse the shares on
the laptop after entering my username/password. When I browse with the
laptop, trying to browse the shares on the desktop causes nautilus to
crash with a sefgmentation fault, there is no password prompt, it just
crashes (and restarts itself cleanly).

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. On the non-master browser, with OS level 20, from the Applications
menu, select 'Network Servers'
2. click on the workgroup icon
3. click on the desktop (master browser, OS level 33) icon

Actual Results:  nautilus crashes

Expected Results:  password prompt followed by listing of shares

Additional info:
Comment 1 Alexander Larsson 2004-02-06 11:16:34 EST
I think this is fixed in 2.5. Can you try rawhide?
Comment 2 Justin Georgeson 2004-02-06 22:11:44 EST
A recent update, I think iptables 1.2.9-1.0, fixed it. Really weird
since I had the iptables service off on both the laptops I had this
problem on. The second laptop I didn't have the SMB server components
installed, so I tried that on the first laptop too, but that didn't
make a difference. So where I am now is a desktop (the one configured
as the master browser) with the server and client installed, and it
works fine. And I have two laptops with only the client installed, and
after updating today (iptables is the only thing that looked relevant)
they can both browse without crashing. I have one wifi card that I
swap between the laptops (a linksys wpc11 v3), not sure if there's any
relevance there. Anyway, I don't think it was the nautilus packages
after all. This bug can be marked resolved.
Comment 3 Alexander Larsson 2004-02-09 04:27:43 EST
Whatever was causing it, nautilus shouldn't crash. However, i think
this is fixed.

Note You need to log in before you can comment on or make changes to this bug.