Bug 1105606 - Puppet classes: Hostnames obscured while trying to choose a server to import, when multiple capsules exist
Summary: Puppet classes: Hostnames obscured while trying to choose a server to import,...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: 6.0.3
Hardware: Unspecified
OS: Unspecified
unspecified
low vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Kedar Bidarkar
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-06-06 13:58 UTC by Corey Welton
Modified: 2019-09-26 14:32 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 08:41:10 UTC


Attachments (Terms of Use)
screenshot (11.97 KB, image/png)
2014-06-06 13:59 UTC, Corey Welton
no flags Details
long hostname puppet class imports (64.84 KB, image/png)
2016-04-13 09:51 UTC, Kedar Bidarkar
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description Corey Welton 2014-06-06 13:58:20 UTC
Description of problem:
When a user has more than one capsule installed (say, default server + external capsule) and tries to import, the "import" button becomes a dropdown to choose which to import from. hostnames in this dropdown are obscured by border of browser however, and no resizing fixes it.

Version-Release number of selected component (if applicable):
Satellite-6.0.3-RHEL-6-20140605.0

How reproducible:


Steps to Reproduce:
1.  Create/register an external capsule.  Might want to make sure the hosts have reasonably long hostnames
2.  Configuration > Puppet Classes
3.  Click the import button

Actual results:
Hostnames get obscured off the side of the browser window.  cannot resize to see complete hostnames.

Expected results:
hostnames are fully readable.

Additional info:

Comment 1 Corey Welton 2014-06-06 13:59:43 UTC
Created attachment 902934 [details]
screenshot

Comment 3 Dominic Cleal 2014-06-12 14:19:56 UTC
This is more of an issue in Sat6 than in Foreman, since Sat6 uses Patternfly and variable width pages, while the fixed-width tables in Foreman mean that on most screen sizes there's still space around the table.

Comment 4 Dominic Cleal 2014-06-12 14:20:19 UTC
Created redmine issue http://projects.theforeman.org/issues/6194 from this bug

Comment 5 Bryan Kearney 2016-02-02 11:10:39 UTC
Upstream bug component is WebUI

Comment 6 Brad Buckingham 2016-03-09 01:17:36 UTC
The behavior on Satellite 6.2 Snap 2 looks different than originally reported.  On my install, the button includes 'Import [my.fqdn.com]' and does not appear to be cut off.  Moving to ON_QA for verification.

Comment 8 Kedar Bidarkar 2016-04-13 09:50:17 UTC
Now even, Long hostnames are clearly visible.

VERIFIED with sat62-snap7.1

Comment 9 Kedar Bidarkar 2016-04-13 09:51:08 UTC
Created attachment 1146780 [details]
long hostname puppet class imports

Comment 11 errata-xmlrpc 2016-07-27 08:41:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.