Bug 1105630 - Missing or wrong version of dependency 'gen/parrot/stage2/QRegex.nqp'
Summary: Missing or wrong version of dependency 'gen/parrot/stage2/QRegex.nqp'
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: rakudo-star
Version: 20
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Gerd Pokorra
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-06-06 15:01 UTC by Manfred Lotz
Modified: 2015-04-02 15:33 UTC (History)
3 users (show)

Fixed In Version: moarvm-0.2014.12-1.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-16 23:30:53 UTC
Type: Bug


Attachments (Terms of Use)

Description Manfred Lotz 2014-06-06 15:01:48 UTC
Description of problem:
Running perl6 gives error: 
Missing or wrong version of dependency 'gen/parrot/stage2/QRegex.nqp'

Version-Release number of selected component (if applicable):


I have installed:
parrot-6.1.0-1.fc20.x86_64
rakudo-star-0.0.2014.03_6.1.0-1.fc20.x86_64
nqp-0.0.2014.03-2.fc20.x86_64


How reproducible:


Steps to Reproduce:
1. run perl6

Actual results:

Missing or wrong version of dependency 'gen/parrot/stage2/QRegex.nqp'
current instr.: '' pc 16529 (src/gen/perl6-pod.pir:6594) (src/Perl6/Pod.nqp:499)
called from Sub '' pc 1819 (gen/parrot/stage2/module_loader.pir:848) (src/vm/parrot/ModuleLoader.nqp:47)
called from Sub '' pc 1847 (gen/parrot/stage2/module_loader.pir:857) (src/vm/parrot/ModuleLoader.nqp:55)
called from Sub 'load_module' pc 1715 (gen/parrot/stage2/module_loader.pir:796) (src/vm/parrot/ModuleLoader.nqp:52)
called from Sub '' pc 195128 (src/gen/perl6-actions.pir:78209) (src/Perl6/Actions.nqp:7241)
called from Sub '' pc 1819 (gen/parrot/stage2/module_loader.pir:848) (src/vm/parrot/ModuleLoader.nqp:47)
called from Sub '' pc 1847 (gen/parrot/stage2/module_loader.pir:857) (src/vm/parrot/ModuleLoader.nqp:55)
called from Sub 'load_module' pc 1715 (gen/parrot/stage2/module_loader.pir:796) (src/vm/parrot/ModuleLoader.nqp:52)
called from Sub '' pc 365992 (src/gen/perl6-grammar.pir:127146) (src/Perl6/Grammar.nqp:4397)
called from Sub '' pc 1819 (gen/parrot/stage2/module_loader.pir:848) (src/vm/parrot/ModuleLoader.nqp:47)
called from Sub '' pc 1847 (gen/parrot/stage2/module_loader.pir:857) (src/vm/parrot/ModuleLoader.nqp:55)
called from Sub 'load_module' pc 1715 (gen/parrot/stage2/module_loader.pir:796) (src/vm/parrot/ModuleLoader.nqp:52)
called from Sub '' pc 753 (src/gen/perl6.pir:290) (gen/parrot/main.nqp:60)

Expected results:
no error

Additional info:

Comment 1 Gerd Pokorra 2014-06-08 08:03:25 UTC
I can reproduce the error. There is a problem with the packages. I will try to fix it next week.

Comment 2 Manfred Lotz 2014-06-08 09:04:24 UTC
(In reply to Gerd Pokorra from comment #1)
> I can reproduce the error. There is a problem with the packages. I will try
> to fix it next week.

Thanks, Gerd. That sounds good.

Comment 3 Gerd Pokorra 2014-06-11 19:42:35 UTC
npq works:

> nqp-p --version
This is nqp version 2014.03 built on parrot 6.1.0 revision 0


A scratch build for f20 is at:
http://koji.fedoraproject.org/koji/taskinfo?taskID=7036714

The rpms her are working.

- for x86-64
yum earse rakudo-star
wget https://kojipkgs.fedoraproject.org//work/tasks/6716/7036716/rakudo-star-0.0.2014.03_6.1.0-1.fc20.x86_64.rpm
yum localinstall rakudo-star.x86_64 0:0.0.2014.03_6.1.0-1.fc20


A rebuild for f20 is yust running:
http://koji.fedoraproject.org/koji/taskinfo?taskID=7036771

Comment 4 Fedora Update System 2014-06-12 01:05:30 UTC
rakudo-star-0.0.2014.03_6.1.0-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/rakudo-star-0.0.2014.03_6.1.0-2.fc20

Comment 5 lnie 2014-06-12 02:47:17 UTC
rakudo-star-0.0.2014.03_6.1.0-2.fc20 works

Comment 6 Manfred Lotz 2014-06-12 03:25:07 UTC
For testing I installed https://kojipkgs.fedoraproject.org//work/tasks/6716/7036716/rakudo-star-0.0.2014.03_6.1.0-1.fc20.x86_64.rpm which works fine now.

Thanks for fixing.

-- Manfred

Comment 7 Fedora Update System 2014-06-13 05:31:30 UTC
Package rakudo-star-0.0.2014.03_6.1.0-2.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing rakudo-star-0.0.2014.03_6.1.0-2.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-7341/rakudo-star-0.0.2014.03_6.1.0-2.fc20
then log in and leave karma (feedback).

Comment 8 Fedora Update System 2014-06-16 23:30:53 UTC
rakudo-star-0.0.2014.03_6.1.0-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 cnangel 2015-01-12 05:32:28 UTC
(In reply to Fedora Update System from comment #8)
> rakudo-star-0.0.2014.03_6.1.0-2.fc20 has been pushed to the Fedora 20 stable
> repository.  If problems still persist, please make note of it in this bug
> report.

i have the same question in fedora21, and run perl6 strill occur some error like this:
[cnangel@localhost ~]$perl6
Unhandled exception: Missing or wrong version of dependency 'gen/moar/stage2/QRegex.nqp'
   at <unknown>:1  (/usr/languages/nqp/lib/Perl6/Pod.moarvm::234)
 from src/vm/moar/ModuleLoader.nqp:50  (/usr/languages/nqp/lib/ModuleLoader.moarvm::80)
 from src/vm/moar/ModuleLoader.nqp:58  (/usr/languages/nqp/lib/ModuleLoader.moarvm:load_module:60)
 from <unknown>:1  (/usr/languages/nqp/lib/Perl6/Actions.moarvm::62)
 from src/vm/moar/ModuleLoader.nqp:50  (/usr/languages/nqp/lib/ModuleLoader.moarvm::80)
 from src/vm/moar/ModuleLoader.nqp:58  (/usr/languages/nqp/lib/ModuleLoader.moarvm:load_module:60)
 from <unknown>:1  (/usr/languages/nqp/lib/Perl6/Grammar.moarvm::73)
 from src/vm/moar/ModuleLoader.nqp:51  (/usr/languages/nqp/lib/ModuleLoader.moarvm::87)
 from src/vm/moar/ModuleLoader.nqp:58  (/usr/languages/nqp/lib/ModuleLoader.moarvm:load_module:60)
 from <unknown>:1  (/usr/languages/perl6/runtime/perl6.moarvm::40)
[cnangel@localhost ~]$rpm -qf /usr/bin/perl6
rakudo-star-0.0.2014.04_6.1.0-2.fc21.x86_64
[cnangel@localhost ~]$rpm -q parrot
parrot-6.1.0-3.fc21.x86_64

Comment 10 Fedora Update System 2015-01-21 11:21:11 UTC
moarvm-0.2014.04-6.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/moarvm-0.2014.04-6.fc21

Comment 11 Gerd Pokorra 2015-01-22 07:55:14 UTC

*** This bug has been marked as a duplicate of bug 1184549 ***

Comment 12 Fedora Update System 2015-03-21 18:46:32 UTC
moarvm-0.2014.12-1.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/moarvm-0.2014.12-1.fc21

Comment 13 Fedora Update System 2015-04-02 15:33:16 UTC
moarvm-0.2014.12-1.fc21 has been pushed to the Fedora 21 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.