Bug 110566 - Timeout error occurred trying to start MySQL Daemon
Summary: Timeout error occurred trying to start MySQL Daemon
Status: CLOSED DUPLICATE of bug 108779
Alias: None
Product: Fedora
Classification: Fedora
Component: mysql (Show other bugs)
(Show other bugs)
Version: 1
Hardware: i686 Linux
medium
low
Target Milestone: ---
Assignee: Kim Ho
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-11-21 13:41 UTC by Nodrahc Technologies Inc.
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:00:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Nodrahc Technologies Inc. 2003-11-21 13:41:51 UTC
Description of problem:

After upgrading from RedHat 9, following error showed up during boot:
Timeout error occurred trying to start MySQL Daemon. The new script
that starts mysqld is at fault. In particular, the command
"/usr/bin/mysqladmin ping" fails if mysql root password is set.

Version-Release number of selected component (if applicable):

mysql-server-3.23.58-4

How reproducible:

Always, if mysql root password is set

Steps to Reproduce:

bash-2.05b# /etc/rc.d/init.d/mysqld status
mysqld (pid 16723) is running...
bash-2.05b# /etc/rc.d/init.d/mysqld stop
Stopping MySQL:                                            [  OK  ]
bash-2.05b# /etc/rc.d/init.d/mysqld start
Timeout error occurred trying to start MySQL Daemon.
Starting MySQL:                                            [FAILED]
bash-2.05b# /etc/rc.d/init.d/mysqld status
mysqld (pid 16826) is running...

Actual results:

Get failed message

Expected results:

Should have started normally

Additional info:

The bug is in the starting script, and it only fails to display that
the server is up. The server actually starts properly, so priority to
fix this is low. 
I have isolated the problem to the command "/usr/bin/mysqladmin ping"
which returns:
  bash-2.05b# /usr/bin/mysqladmin ping
  /usr/bin/mysqladmin: connect to server at 'localhost' failed
  error: 'Access denied for user: 'root@localhost' (Using password: NO)'

That's because the mysql root account is pasword protected, as it
should be. If I do:
  bash-2.05b# /usr/bin/mysqladmin ping -p
  Enter password:
  mysqld is alive
all is well, but of course you can't do that during boot. The RedHat 9
mysqld starting script works fine with a mysql root password.

Comment 1 Kim Ho 2003-11-21 15:18:54 UTC

*** This bug has been marked as a duplicate of 108779 ***

Comment 2 Rahul Prakash 2005-09-29 15:24:34 UTC
I tried the following and now I cannot even start my mysqld:
 
mysql> UPDATE mysql.user SET Password = PASSWORD('12345')
    ->     WHERE User = 'root';
mysql> FLUSH PRIVILEGES;

###After this I did an exit and then tried the following:

[root@netd rprakash]#  service mysqld start
Timeout error occurred trying to start MySQL Daemon.
Starting MySQL:                                            [FAILED]

[root@netd rprakash]# mysql
ERROR 1045: Access denied for user: 'root@localhost' (Using password: NO)

I am only a beginner in this field. Could anyone kindly sugest me a work-around
to restart my mysqld.
Thanks

Comment 3 Red Hat Bugzilla 2006-02-21 19:00:06 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.