Bug 110596 - SiteBanner should be updated to use WebConfig, site-banner.xsl should likewise be fixed
SiteBanner should be updated to use WebConfig, site-banner.xsl should likewis...
Status: CLOSED WONTFIX
Product: Red Hat Web Application Framework
Classification: Retired
Component: other (Show other bugs)
nightly
All Linux
medium Severity low
: ---
: ---
Assigned To: ccm-bugs-list
Jon Orris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-11-21 11:34 EST by Vadim Nasardinov
Modified: 2007-04-18 12:59 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-03 14:37:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vadim Nasardinov 2003-11-21 11:34:59 EST
At the bottom of "/ccm/pvt/" there is the following note:

   If you encounter any problems using example.com:9000,
   please contact the site administrator. 

where "example.com:9000" is linked to "http://example.com"
with no port number.  The port number is lost because,
site-banner.xsl derives the URL from the "hostname" attribute
of the following element:
    <ui:siteBanner admin="" hostname="example.com" 
     metadata.tag="bottom" sitename="example.com:9000"/>

The attribute is produced by SiteBanner.java which relies
on the deprecated class KernelHelper.java.  SiteBanner.java
should be updated to make use of WebConfig.java, and site-banner.xsl
should generated the correct URL.
Comment 1 Daniel Berrange 2003-11-21 11:46:25 EST
In p4 37829, Justin made KernelHelper delegates to WebConfig. It looks
like there is a small change in the semantics of
KernelHelper#getHostName. Previously we always configured
kernel.Initializaer#hostname to include the port number, by the
delegation from KernelHelper only has the hostname. 

As for 'sitename' attribute, this is controlled by waf.web.site_name
config param, which is setup to default to whatever
WebConfig#getServer().toString() returns. What is should contain is
the human friendly sitename, eg 'Red Hat CCM Demo' or whatever.

To be honest its probably time we removed KernelHelper altogether
since its been deprecated since 5.l core IIRC.
Comment 2 Vadim Nasardinov 2005-08-03 14:37:27 EDT
stale

Note You need to log in before you can comment on or make changes to this bug.