Bug 1106071 - BUG: libseccomp FTBFS in rawhide
Summary: BUG: libseccomp FTBFS in rawhide
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: libseccomp
Version: rawhide
Hardware: armv7hl
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Paul Moore
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On: 1111726
Blocks: ARMTracker F21FTBFS
TreeView+ depends on / blocked
 
Reported: 2014-06-09 02:26 UTC by Dennis Gilmore
Modified: 2014-09-18 21:41 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2014-09-18 21:41:36 UTC


Attachments (Terms of Use)
build.log (256.68 KB, text/plain)
2014-06-09 02:26 UTC, Dennis Gilmore
no flags Details
root.log (74.16 KB, text/plain)
2014-06-09 02:26 UTC, Dennis Gilmore
no flags Details
state.log (1.08 KB, text/plain)
2014-06-09 02:26 UTC, Dennis Gilmore
no flags Details

Description Dennis Gilmore 2014-06-09 02:26:44 UTC
Your package libseccomp failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=6945825

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild

Comment 1 Dennis Gilmore 2014-06-09 02:26:48 UTC
Created attachment 903795 [details]
build.log

Comment 2 Dennis Gilmore 2014-06-09 02:26:50 UTC
Created attachment 903796 [details]
root.log

Comment 3 Dennis Gilmore 2014-06-09 02:26:51 UTC
Created attachment 903797 [details]
state.log

Comment 4 Paul Moore 2014-06-17 13:32:20 UTC
Looking at the logs, it is the regression tests with valgrind that appear to be failing.

Comment 5 Yaakov Selkowitz 2014-06-20 00:01:55 UTC
These tests only fail on arm; they pass on both ix86 and x86_64.  Also notable is that "only" ~4000 tests are attempted on arm vs ~6500 for x86.

Comment 6 Paul Moore 2014-06-20 15:02:03 UTC
Thanks for the clarification, I hadn't yet looked too closely at the logs.  I've updated the BZ info above.

Also, as far as the test go, not all of the regression run on all of the different architectures/ABIs so having a different number of tests between x86_64 and arm is expected.

Comment 7 Paul Moore 2014-06-20 15:03:46 UTC
Yaakov,

Are you aware of any problems with valgrind on Rawhide/arm at the moment?  I ask because it seems somewhat suspicious that we only see these failures on arm and not the other Rawhide supported arch/ABIs.

Comment 8 Yaakov Selkowitz 2014-06-20 20:37:08 UTC
(In reply to Paul Moore from comment #7)
> Are you aware of any problems with valgrind on Rawhide/arm at the moment?  I
> ask because it seems somewhat suspicious that we only see these failures on
> arm and not the other Rawhide supported arch/ABIs.

Very possibly; following up in bug 1111726.

Comment 9 Paul Moore 2014-08-06 20:04:57 UTC
Added a request for the valgrind suppression output in the other BZ.  If we can create a suppression file we can include it in the package so that the valgrind tests will pass.

Comment 10 Paul Moore 2014-09-18 21:03:47 UTC
The updated valgrind appears to have solved the problem when building for i686, x86_64, and armv7hl.

Comment 11 Paul Moore 2014-09-18 21:14:15 UTC
Koji scratch build:

 * http://koji.fedoraproject.org/koji/taskinfo?taskID=7621290

Comment 12 Paul Moore 2014-09-18 21:18:36 UTC
Pushed upstream:

# fedpkg commit
[master 207be65] - Fully builds on i686, x86_64, and armv7hl (RHBZ #1106071)
 1 file changed, 4 insertions(+), 4 deletions(-)
# fedpkg push
Counting objects: 3, done.
Delta compression using up to 4 threads.
Compressing objects: 100% (3/3), done.
Writing objects: 100% (3/3), 490 bytes | 0 bytes/s, done.
Total 3 (delta 1), reused 0 (delta 0)
remote: Emitting a message to the fedmsg bus.
To ssh://pcmoore@pkgs.fedoraproject.org/libseccomp
   3ebaa30..207be65  master -> master

Comment 13 Paul Moore 2014-09-18 21:20:18 UTC
Corrected a changelog typo:

# fedpkg commit
[master fc3951d] Fixed a typo in the last changelog date stamp
 1 file changed, 1 insertion(+), 1 deletion(-)
# fedpkg push
Counting objects: 3, done.
Delta compression using up to 4 threads.
Compressing objects: 100% (3/3), done.
Writing objects: 100% (3/3), 377 bytes | 0 bytes/s, done.
Total 3 (delta 1), reused 0 (delta 0)
remote: Emitting a message to the fedmsg bus.
To ssh://pcmoore@pkgs.fedoraproject.org/libseccomp
   207be65..fc3951d  master -> master

Comment 14 Paul Moore 2014-09-18 21:41:36 UTC
Build:

 * http://koji.fedoraproject.org/koji/taskinfo?taskID=7621505


Note You need to log in before you can comment on or make changes to this bug.