Bug 11061 - jade generates bad TeX output
Summary: jade generates bad TeX output
Status: CLOSED DUPLICATE of bug 10944
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: jade (Show other bugs)
(Show other bugs)
Version: 6.2
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-04-26 22:43 UTC by ramon
Modified: 2014-03-17 02:13 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-05 15:36:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description ramon 2000-04-26 22:43:53 UTC
Output produced by Jade for TeX does not work. The TeX output contains a
line with garbage:

{^@^@}\def\sbNom%

(^@ stands for ASCII 0 here)
which causes TeX to complain.

Some input:

<!DOCTYPE chapter PUBLIC "-//OASIS//DTD DocBook V3.1//EN">
<chapter> <title> This is a title </title>
<sect1> <title> A section </title>
<para>
This is some text
</para>
</sect1>
</chapter>

jl1.quim.ucm.es~> jade -t tex -d \
/usr/lib/sgml/stylesheets/nwalsh-modular/print/plain.dsl -o kk.tex kk.sgml

jl1.quim.ucm.es~> jadetex kk.tex
[output omitted]
! Text line contains an invalid character.
l.203 {^^@
          ^^@}\def\sbNom%
! Text line contains an invalid character.
l.203 {^^@^^@
             }\def\sbNom%
[1.0.12] [2.0.12] (kk.aux) )
[more output omitted]



This makes docbook pretty unusable, at least for printing. Automatic
conversion from docbook to dvi or pdf, using the commands db2dvi and
db2pdf does not work for the reason above.

Comment 1 Bill Nottingham 2000-05-05 15:36:59 UTC
*** This bug has been marked as a duplicate of 10944 ***


Note You need to log in before you can comment on or make changes to this bug.